ERROR

No se puede iniciar sesión usando IDP. No se encontró 'NAME_ID' en la respuesta de SAML para AD FS

Last Published: July 22, 2021

Mensaje de error

Al utilizar el IDP de SAML de Active Directory Federation Services (AD FS), aparece el siguiente error al intentar iniciar sesión en el portal de ArcGIS Enterprise mediante inicios de sesión SAML:

No se puede iniciar sesión usando IDP. No se encontró 'NAME_ID' en la respuesta de SAML

Causa

El atributo SAML NameID no se encuentra en el elemento <Subject> de la respuesta de la aserción SAML.

Solución o solución alternativa

  1. Abra la consola de administración de AD FS.
  2. Seleccione Grupos de partes que confían. En la ventana Grupos de partes que confían, seleccione el SP correspondiente a su portal de Enterprise.
  3. En la pestaña Acciones, haga clic en Editar política de emisión de reclamación (ADFS 4) o Editar reglas de reclamación (ADFS 3), seleccione la Regla de transformación de emisión y haga clic en Editar regla.
  4. En la ventana Editar regla, haga clic en Ver idioma de regla.
  5. Verifique que el atributo Id. de nombre se envíe con el tipo: http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier
  6. Si falta este atributo, agregue una nueva reclamación al atributo Id. de nombre. En el tipo de reclamación Saliente, elija el valor Id. de nombre en la lista desplegable de opciones.

Id. de artículo:000026098

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