CÓMO

No se pueden guardar los símbolos personalizados en el Selector de símbolo

Last Published: October 1, 2025

Descripción

Los cuadros de diálogo del Selector de símbolo muestran una paleta de símbolos que se encuentran en cualquiera de los estilos a los que se hace referencia actualmente o en los estilos personales de un usuario. Con el Selector de símbolo, los usuarios pueden implementar símbolos personalizados si ninguno de los símbolos deseados está presente en la paleta o es difícil de encontrar.

Sin embargo, los usuarios no pueden guardar los símbolos personalizados en el Selector de símbolo si el botón Guardar como del cuadro de diálogo del Selector de símbolo está deshabilitado.

[O-Image]

Causa

El botón puede estar deshabilitado por alguna de las siguientes razones:

  • El archivo .style está definido como Solo lectura.
  • Se ha producido un problema relacionado con el archivo Normal.mxt.
  • Los datos o el archivo MXD están dañados.

Solución o solución alternativa

En función de la causa, se pueden aplicar las siguientes alternativas.

Note:
Close all Esri applications running on the system before proceeding to the workaround.

Asegúrese de que dispone de acceso de lectura y escritura para el archivo .style

Este archivo se encuentra en:

C:\Users\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap
Note:
Enable 'Show Hidden Files and Folders' if unable to locate the application data folder. This can be done in Windows 7 or 8 by clicking Organize Drop-down > Folder and Search Options > View Tab > Show Hidden Files and Folders.
[O-Image]

Cambie el nombre del archivo Normal.mxt

  1. Vaya a la siguiente ruta de directorio:
C:\User\*username*\AppData\Roaming\ESRI\Desktop10.x\ArcMap\Templates
  1. Haga clic con el botón derecho en el archivo Normal.mxt y haga clic en Cambiar nombre.
  2. Cambie el nombre del archivo a "Normal_anterior.mtx".
  3. Inicie ArcMap.
Warning:
The instructions below include making changes to essential parts of the operating system. Esri recommends performing a back up of the operating system and files, including the registry, before proceeding. Consult a qualified computer systems professional if necessary.
Be aware that renaming the Esri folders is a factory reset of ArcGIS, and therefore all third party tools, custom scripts, or custom toolbars currently installed must be reinstalled accordingly. Additionally, all existing folder connections must be reconnected.
Esri cannot guarantee results from incorrect modifications while following these instructions. Proceed with caution.
Note:
If ArcGIS Pro is installed on the machine, ensure that an ArcGIS Pro license is not checked out from ArcGIS Online.
If unsure that the ArcGIS Pro license is checked out on the machine, contact Esri Technical Support at 888-377-4575.

Cambiar el nombre de una carpeta Esri

  1. Abra el Explorador de Windows.
  2. Vaya a
C:\Users\*username*\AppData\Roaming\ESRI
  1. Haga clic con el botón derecho en la carpeta Esri y seleccione Cambiar nombre. Cambie el nombre de la carpeta a "ESRI_anterior".

Editar la clave de registro

  1. Haga clic en el menú Iniciar > Ejecutar > escriba regedit.
  2. En el Editor del Registro, expanda la carpeta HKEY_CURRENT_USER.
  3. Expanda la carpeta Software.
  4. Cambie el nombre de la carpeta Esri a "Esri_anterior".
[O-Image]
  1. Cierre la ventana Editor del Registro.
  2. Inicie ArcMap.

Id. de artículo: 000012396

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga