Descripción
Al hacer clic en el botón Mapa base en el Visor de mapas de ArcGIS Online, la visualización de la galería de mapas base de Esri falla al completo.
Causa
Estas son algunas de las posibles causas de ese problema:
- La configuración de seguridad permite mezcla de contenido HTTP y HTTPS. El error frecuente que aparece al encontrarse con este problema es el error "403 Prohibido". Se trata de un código de estado HTTP que indica que se ha denegado el acceso a la página web concreta.
Nota:
El siguiente documento de la Ayuda de ArcGIS Online describe el comportamiento de un entorno que utiliza mezcla de contenido: Ayuda de ArcGIS Online: Solución de problemas.
- Problemas de caché del navegador
- Se ha cambiado la Galería de mapas base predeterminada configurada para la organización
Solución o solución alternativa
Estas son algunas de las posibles soluciones para este problema:
- Utilizar el ArcGIS Online Health Dashboard
El ArcGIS Online Health Dashboard es una página de estado que proporciona información actual respecto a la disponibilidad de servicio de ArcGIS Online. La información proporcionada tiene que ver con la salud general del sistema de ArcGIS Online. Aparece un mensaje de interrupción del servicio cuando un servicio concreto deja de estar disponible. Si existe algún problema conocido con los mapas base predeterminados de ArcGIS Online, aparece enumerado aquí. La página ArcGIS Online Health Dashboard puede verse en: ArcGIS Online Health Dashboard.
- Configurar ArcGIS Online con la configuración de seguridad apropiada
Determinadas capas no se visualizan debidamente con mezcla de contenido. También depende del navegador web utilizado para visualizar el contenido. El siguiente documento de la Ayuda de ArcGIS Online describe las opciones de seguridad disponibles y cómo configurar los ajustes de seguridad: Configurar los ajustes de seguridad.
- Probar otro navegador
Si los mapas base se visualizan correctamente en otro navegador, es posible que al borrar la caché del navegador original se resuelva el problema.
- Comprobar qué galería de mapas base se ha configurado para la organización
Determinadas capas no se visualizan debidamente con mezcla de contenido.
- Inicie sesión en ArcGIS Online con una cuenta de administrador.
- Haga clic en Mi organización > Editar ajustes > Mapa.
- Tome nota del grupo seleccionado en la Galería de mapas base.
La galería de mapas base solo muestra los mapas base predeterminados si Predeterminado de Esri está seleccionado o si se ha seleccionado un grupo personalizado y los mapas base de Esri se han compartido con ese grupo personalizado.
- Volver a asociar los mapas base predeterminados de Esri con la galería de mapas base
Los siguientes pasos detallan este flujo de trabajo:
Cree un nuevo Grupo para almacenar los mapas base predeterminados de Esri.
- Haga clic en Grupos > CREAR UN GRUPO.
- Especifique un nombre para el grupo que acaba de crear y deje el resto de opciones de la forma predeterminada.
- Haga clic en Guardar.
Cambie el grupo utilizado para la Galería de mapas base.
- Haga clic en Mi organización, haga clic en EDITAR AJUSTES y, a continuación, en Mapa.
- En la opción Galería de mapas base, haga clic en la flecha desplegable y seleccione el grupo que acaba de crear.
- Active la opción Compartir los mapas base predeterminados de Esri con este grupo haciendo clic en Guardar. Al activar esta opción, los mapas base predeterminados de Esri se incluyen al grupo que acaba de crear.
- Haga clic en Guardar.
- Haga clic en Mapa y, luego, en el widget Mapa base para comprobar que la galería de mapas base esté disponible.