PROBLEMA

No se puede instalar un paquete de Python en el Administrador de paquetes Python de ArcGIS Pro

Last Published: April 25, 2020

Descripción

Al instalar un paquete de Python en el Administrador de paquetes Python de ArcGIS Pro, el botón Instalar está deshabilitado.

Causa

A partir de ArcGIS Pro 2.2., el entorno predeterminado de arcgispro-py3 está configurado como de solo lectura, por lo que no es posible instalar ningún nuevo paquete en el entorno predeterminado.

Solución o solución alternativa

Cree o clone un entorno a partir del entorno predeterminado e instale el paquete de Python en el nuevo entorno. Siga estos pasos para clonar un entorno.

  1. Inicie ArcGIS Pro y abra un proyecto.
  2. Haga clic en Proyecto > Python.
  3. Haga clic en Administrar entornos.
    Phython Package Manager
  4. Haga clic en Clonar.
    Manage Environments window
  5. Marque el entorno clonado como Activo.
    Manage Environments window with active tab
  6. Reinicie ArcGIS Pro.
  7. Instale el paquete de Python.
Nota:
Existe una limitación conocida de la clonación de entornos desde el Administrador de paquetes Python de ArcGIS Pro 2.2. El problema está resuelto en ArcGIS Pro 2.3. Para obtener más información y una alternativa para ArcGIS Pro 2.2, consulte: Problema: No se pueden crear entornos ni instalar paquetes tras actualizarse a ArcGIS Pro 2.2

Id. de artículo: 000020279

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga