CÓMO

La herramienta Validación y reparación deja de responder o se bloquea durante la desinstalación del parche de Portal for ArcGIS

Last Published: July 29, 2024

Descripción

Al ejecutar la herramienta Validación y reparación de Portal for ArcGIS, la ventana de la herramienta deja de responder o se bloquea al desinstalar parches. La verificación de la actividad del sistema operativo (OS) no revela ningún proceso en segundo plano en curso.

Se devuelven los siguientes registros en los registros del Visor de eventos de Windows correspondientes a cada bloqueo:

Los registros del Visor de eventos de Windows correspondientes a cada bloqueo

En algunos casos, se devuelve el siguiente mensaje de error en la ventana Validación y reparación de Portal for ArcGIS 10.8.1:

Error:
There were issues uninstalling patches from your portal machine.
El mensaje de error en la ventana de la herramienta Validación y reparación de Portal for ArcGIS 10.8.1

Al intentar desinstalar los parches desde el Panel de control de Microsoft Windows, aparece el siguiente mensaje de error:

Error: 
The feature you are trying to use is on a network resource that is unavailable.
Note: 
The patches uninstallation process for Portal for ArcGIS 10.8.1 or 10.9.1 taking a longer time is anticipated. Refer to Patches and Updates: Portal for ArcGIS Validation and Repair for more information.

Causa

  • El software antivirus instalado en el equipo bloquea o limita el acceso a uno o más archivos de parche. La conexión a los archivos de parches puede estar bloqueada por reglas de seguridad predeterminadas establecidas por la organización.
  • La herramienta Validación y reparación no puede buscar el archivo de instalación original de Portal for ArcGIS.

Solución o solución alternativa

Dependiendo de las circunstancias, se aplican las soluciones alternativas que se describen a continuación.

Deshabilitar el software antivirus y detener el resto de las tareas

Póngase en contacto con el departamento de TI para deshabilitar el software antivirus y volver a ejecutar la herramienta Validación y reparación. Si esto no resuelve el problema, siga estos pasos para detener las tareas desde la ventana del Administrador de tareas y volver a ejecutar la herramienta Validación y reparación.

  1. Presione las teclas Windows + X y seleccione Administrador de tareas en el menú. Se abre la ventana del Administrador de tareas.
  2. En la pestaña Procesos, seleccione la herramienta Validación y reparación y haga clic en Finalizar tarea.
  3. Seleccione 7za.exe y haga clic en Finalizar tarea.
  4. Cierre la ventana del Administrador de tareas.
  5. Ejecute la herramienta Validación y reparación.

Ejecutar la herramienta Validación y reparación desde el símbolo del sistema

Siga estos pasos si deshabilitar el software antivirus no es una opción viable.

  1. En el cuadro de búsqueda de Windows en la barra de tareas, busque y haga clic con el botón derecho en el Símbolo del sistema de Windows y, a continuación, seleccione Ejecutar como administrador.
  2. En la ventana Administrador: Símbolo del sistema, ejecute el siguiente comando para cambiar el directorio del Símbolo del sistema al directorio que contiene la herramienta Validación y reparación.
C:/<ArcGIS Server installation directory>\<download folder>
  1. Ejecute la herramienta Validación y reparación introduciendo el nombre de la herramienta en la línea de comandos.
ArcGIS-PFA-1081-ValidationRepair.exe
El comando en la ventana Administrador: Símbolo del sistema de Windows

Extraer el archivo de instalación del portal en la ubicación correcta del archivo

Para resolver el mensaje de error, extraiga o descargue el archivo de instalación del portal en la ruta de acceso definida en la propiedad SourceDir del Registro de Windows. La ruta predeterminada para el archivo de instalación extraído es:

C:\Users\<user profile ID>\Documents\ArcGIS 10.8.1\PortalForArcGIS\SetupFiles
  1. Busque la ubicación del archivo de instalación de Portal for ArcGIS:
    1. En el cuadro de búsqueda de Windows en la barra de tareas, busque y haga clic en Editor del Registro.
    2. En la ventana Editor del Registro, copie la siguiente ruta de archivo en el cuadro Buscar.
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\Portal for ArcGIS
El cuadro Buscar en la ventana Editor del Registro
  1. Identifique la ruta de acceso del archivo registrada en la columna Datos de la propiedad SourceDir.
La ruta del archivo de Portal for ArcGIS en la columna Datos de la propiedad SourceDir
  1. Descargue el archivo de instalación de Portal for ArcGIS y ejecútelo para extraerlo en la carpeta SourceDir. Consulte Cómo: Descargar e instalar software desde My Esri para obtener instrucciones.
Warning:
Do not run the setup file after the extraction is completed. Doing so may result in overwriting the existing deployment.
  1. Ejecute la herramienta Validación y reparación.

Id. de artículo: 000032123

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