CÓMO

Se produce un error al publicar un servicio en Portal for ArcGIS con el error "No se encontró ningún servidor de alojamiento"

Last Published: October 1, 2025

Descripción

Los intentos de publicar un servicio en Portal for ArcGIS fallan y se devuelve el siguiente mensaje de error:

Error:
No hosting server found.

Causa

Hay dos posibles causas del problema:

  • La cuenta de usuario no tiene privilegios suficientes para publicar un servicio. Por ejemplo, una cuenta de nivel 1 solo puede acceder a los servicios disponibles. Una cuenta de nivel 2 tiene privilegios de publicación y edición.
  • El Web Adaptor configurado para el servidor que aloja Portal for ArcGIS hace referencia a la URL de forma incorrecta. La dirección URL predeterminada suele tener el siguiente formato:
    https://<FQDN>/<nombre del adaptador web>

    Sin embargo, las configuraciones incorrectas pueden hacer referencia a una dirección URL diferente, por ejemplo:
    https://<FQDN>/<nombre del adaptador web>/rest

Solución o solución alternativa

En función de la causa, utilice una de las siguientes soluciones para corregir el error.

  • Asegúrese de que la cuenta de usuario tenga suficientes privilegios antes de acceder al portal. Para obtener más información, consulte el siguiente documento de ayuda web, Portal for ArcGIS: Niveles, roles y privilegios.
  • Actualice la URL de la página principal de Portal for ArcGIS, https://<FQDN>/<nombre del adaptador web>. El siguiente procedimiento muestra cómo actualizar la URL utilizando el extremo REST de Portal for ArcGIS.
Note:
Only those with the Administrator privileges may perform the following steps.
  1. Inicie sesión en el extremo REST del Directorio de Portal for ArcGIS con una cuenta de administrador y haga clic en Inicio.
Imagen de la página principal de inicio de sesión del Administrador de la página REST de Portal for ArcGIS.
  1. En Inicio, vaya a Recursos secundarios y haga clic en Portales.
Imagen de la página de inicio de REST de Portal for ArcGIS. 
  1. En Raíz de portales, vaya a Recursos secundarios y haga clic en Auto.
Imagen de la página Portales en Portal for ArcGIS REST. 
  1. En Auto, desplácese hacia abajo en la página y haga clic en Servidores.
Imagen de la parte inferior de la página REST de los servidores. 
  1. En Servidores, busque y haga clic en el Id. de servidor que desee.
Imagen del ID de servidor disponible 
  1. Una vez que se determine el Id. del servidor , haga clic en Actualizar servidor. Se abrirá la página Actualizar servidor.
Imagen de la página ID del servidor. 
  1. En Actualizar servidor, cambie la URL para que coincida con la página principal de Portal for ArcGIS. Haga clic en Actualizar. La URL se actualiza.
Imagen de la página del servidor de actualización.

Id. de artículo: 000017526

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga