PROBLEMA

La interfaz de la página Iniciar sesión de Portal for ArcGIS no se visualiza en Chrome

Last Published: April 25, 2020

Descripción

Al utilizar el navegador Chrome para iniciar sesión en un portal de ArcGIS, no se visualiza la sección de inicio de sesión, sino que aparece como un elemento web dañado.

Image of the missing element
Nota:
Para comprobar si se produce este problema, abra las Herramientas para desarrolladores de Chrome (F12) para inspeccionar la consola. En la pestaña Consola, debe haber un error que explique que no es posible mostrar la sección de la interfaz debido a X-Frame-Options.

Causa

Este problema se produce cuando el valor del encabezado X-Frame-Options está establecido como SAMEORIGIN en Web Adaptor.

Solución o solución alternativa

Para resolver este problema, realice lo siguiente en el equipo que tiene Web Adaptor instalado:
  1. Desde el Panel de control de Windows, vaya a las Herramientas administrativas y ejecute el Administrador de Internet Information Systems (IIS).
  2. Expanda los sitios en el panel de la izquierda y haga clic en el Web Adaptor del Portal afectado.
  3. En el panel de la derecha, en la categoría IIS, seleccione la opción Encabezados de respuesta de HTTP.
  4. Haga doble clic en el encabezado X-Frame-Options.
  5. Reemplace los valores de ese campo por:
ALLOW-FROM https://portal.domain/webadaptor
  1. Haga clic en Aceptar.
  2. Abra Chrome y vaya a la página Iniciar sesión para comprobar que se carga el elemento de dicha página.

Id. de artículo:000019542

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema