CÓMO

License Server se bloquea periódicamente

Last Published: May 6, 2024

Descripción

Es posible que los usuarios informen de un bloqueo intermitente de License Server. Por lo general, significa que ocasionalmente el servicio dejará de ejecutarse y License Server Administrator deja de responder. Los usuarios tampoco pueden volver a iniciar el servicio de licencias desde License Server Administrator. Es posible que los usuarios vean el siguiente error en el registro lmgrd:

Wrong hostid on SERVER line for license file:
Server line says VM_UUID=xxxxxxxxxxxxxxx, hostid is VM_UUID=xxxxxxxxxxxxxxxx
Invalid hostid on SERVER line

A continuación, se muestra una imagen de un archivo de registro con este error:

Archivo de registro que muestra el error

Causa

Puede deberse a una configuración del archivo service.txt que haga referencia a una dirección MAC o un UUID de una VM incorrectos. Una dirección MAC o un UUID de una VM en el archivo service.txt indica que las licencias del usuario nominal de ArcGIS Pro para Portal se han autorizado en el servidor de licencias. Parece que existen tres configuraciones que pueden desencadenar este problema:

  • Si existe una discrepancia entre la dirección MAC o el UUID de una VM en el archivo de licencia creado en My Esri y que se especifique en el archivo service.txt. Puede ocurrir si un archivo service.txt se transfiere de una instalación anterior.
  • Si existe una discrepancia entre la dirección MAC o un UUID de una VM especificados en el archivo service.txt y los identificadores reales de la máquina en License Server Administrator.
  • Si se especifica un UUID de una VM que consta únicamente de ceros en los identificadores de máquina de License Server Administrator y, como resultado, se especifica como tal en el archivo de licencia.

Solución o solución alternativa

Detener e iniciar ArcGIS License Service desde la aplicación Servicios resuelve temporalmente el bloqueo; sin embargo, no se resuelve completamente. El problema volverá a producirse si se aplica la configuración incorrecta. El usuario debe editar (o bien cancelar y volver a crear) el archivo de licencia de usuario nominal de My Esri y especificar el UUID de una VM o dirección MAC correctos para que coincidan con los identificadores del equipo de License Server. Para obtener más información sobre la creación del archivo de licencia de usuario nominal, consulte el siguiente vínculo: Crear un archivo de licencia en My Esri para el portal de Enterprise 10.7 y versiones posteriores.

En el caso del tercer problema anterior, en el que se especifica un UUID de una VM que consta únicamente de ceros en los identificadores del equipo de License Server Administrator, es posible que primero sea necesario asignar un UUID de una VM al equipo (si el equipo es una máquina virtual) y el archivo de licencia recreado en My Esri con el UUID correcto de una VM.

Id. de artículo: 000026296

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga