PROBLEMA

Las capas de entidades alojadas no se publican en un portal con el Error 001362 y el Error 001360

Last Published: April 25, 2020

Descripción

Al publicar capas de entidades alojadas en un portal, aparecen los siguientes errores:

Error: 
Error 001362: Error al extraer el manifiesto de la definición de servicio cargada
Error: 
Error 001360: Error al obtener metadatos del elemento básico para cargar la definición de servicio

Causa

Algunas causas conocidas de estos errores, aunque no las únicas, son las siguientes:

ArcGIS Data Store no puede comunicarse con ArcGIS Server o Portal for ArcGIS a través de los protocolos SSL establecidos
Los protocolos SSL configurados o habilitados para los equipos con ArcGIS Data Store, Portal for ArcGIS y ArcGIS GIS Server no son los mismos. Se requiere que todos los equipos tengan los mismos protocolos SSL para publicar correctamente las capas de entidades alojadas.

Las herramientas de publicación no pueden descargar el archivo de definición de servicio del portal a la carpeta Temp de la cuenta de ArcGIS Server
Cuando se publica una capa de entidades alojada, la herramienta de publicación del servidor de alojamiento descarga el archivo de definición de servicio del portal a la carpeta Temp de la cuenta que está ejecutando el servicio de ArcGIS Server en el equipo.

Esta descarga falla si:

  • La cuenta de servicio de ArcGIS Server no tiene los permisos adecuados para la carpeta.
  • La unidad de disco en la que se almacena la carpeta Temp está llena.
  • La carpeta Temp contiene más de 65.000 archivos (este límite varía según el sistema operativo).

Solución o solución alternativa

Utilice una de las siguientes soluciones, en función de la causa:

ArcGIS Data Store no puede comunicarse con ArcGIS Server o Portal for ArcGIS a través de los protocolos SSL establecidos
  1. Determine los protocolos SSL utilizados por ArcGIS Server y Portal for ArcGIS.
    1. Para comprobar el actual protocolo SSL utilizado por ArcGIS Server, inicie sesión en el Directorio de administrador de ArcGIS Server (https://..com//admin) como administrador.
    2. Haga clic en seguridad > config. Tome nota de las versiones de TLS habilitadas junto a Protocolos SSL.
Nota:
TLS v1.2 y TLS v1.1 son los protocolos SSL predeterminados para la implementación base de ArcGIS Enterprise a partir de la versión 10.6.1.
  1. Para comprobar el actual protocolo SSL utilizado por Portal for ArcGIS, inicie sesión en el Directorio de administrador de Portal (https://..com//admindelportal) como administrador.
  2. Haga clic en Seguridad > SSLCertificates. Tome nota de las versiones de TLS habilitadas, que se enumeran en el campo Protocolos SSL de servidor web.
Nota:
Asegúrese de que los protocolos de ArcGIS Server y Portal for ArcGIS coincidan. Para obtener más información sobre la configuración de protocolos en ArcGIS Server y Portal for ArcGIS, consulte ArcGIS Server: Comunicación segura de ArcGIS Server (para ArcGIS Server) y Portal for ArcGIS: Restringir protocolos TLS y conjuntos de cifrado (para Portal for ArcGIS).
  1. Habilite los protocolos de cada equipo.
    1. En el equipo de ArcGIS Server, abra la aplicación Servicios desde el menú Inicio de Windows.
Nota:
Para encontrar la aplicación Servicios, busque desde el menú Inicio de Windows o escriba services.msc en el cuadro de diálogo Inicio > Ejecutar y pulse Intro.
  1. Tome nota del propietario del servicio de ArcGIS Server en la columna Iniciar sesión como.
  1. Inicie sesión en el equipo de ArcGIS Server como la cuenta que ejecuta el servicio de ArcGIS Server.
  2. Desde el menú Inicio de Windows, busque y haga clic en Opciones de Internet.
  3. En la pestaña Opciones avanzadas, busque la sección Configuración y compruebe los protocolos que coincidan con los del Paso 1.
Nota:
Puede que sea necesario consultar al departamento de TI para cambiar estos protocolos.
  1. Repita los Pasos del a al e en los equipos con Portal for ArcGIS y ArcGIS Data Store instalados.
Las herramientas de publicación no pueden descargar el archivo de definición de servicio del portal a la carpeta Temp de la cuenta de ArcGIS Server
  1. Otorgue a la cuenta de ArcGIS Server control total sobre su carpeta Temp.
    1. En el equipo de ArcGIS Server, abra la aplicación Servicios desde el menú Inicio de Windows.
    2. Tome nota del propietario del servicio de ArcGIS Server en la columna Iniciar sesión como.
    3. Inicie sesión en el equipo de ArcGIS Server como la cuenta que ejecuta el servicio de ArcGIS Server.
    4. En el Explorador de archivos de Windows, vaya a la carpeta Temp.
Nota:
La ubicación predeterminada de la carpeta temporal es C:\Usuarios\Default\AppData\Local.
  1. Haga clic con el botón derecho en la carpeta y, a continuación, haga clic en Propiedades > Seguridad.
  2. Marque la cuenta de servicio de ArcGIS Server y active la casilla situada junto a Control total en Permisos de. Haga clic en Aplicar.
  1. Compruebe el espacio en disco disponible en la unidad de disco en la que se encuentra la carpeta Temp de la cuenta de servicio de ArcGIS Server.
    1. En el Explorador de archivos de Windows, haga clic con el botón derecho en la unidad en la que se encuentra la carpeta Temp (generalmente, la unidad C). Haga clic en Propiedades.
    2. Compruebe la cantidad de espacio libre de la que dispone. Si hay poco o nada de espacio libre, haga clic en el botón Liberar espacio para borrar archivos innecesarios.
  1. Borre los archivos almacenados en la carpeta Temp.
    1. Vaya a la carpeta Temp. Hacer clic con el botón derecho en la carpeta Temp y haga clic en Propiedades.
    2. En la pestaña General, compruebe el número de archivos encontrados. Si este número supera los límites del sistema operativo, elimine archivos que ya no sean necesarios.

Id. de artículo: 000019726

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