PROBLEMA

Los miembros de grupos corporativos se quedan sin acceso al contenido de forma periódica

Last Published: April 25, 2020

Descripción

Los miembros de grupos corporativos configurados con un proveedor de identidades corporativas (como Active Directory) dejan de tener acceso al contenido compartido y de aparecer en la lista de miembros de un grupo.

Los usuarios pueden indicar que el problema se resuelve solo en 24 horas o después de cerrar sesión y volver a entrar.

Causa

Esto se debe a que el controlador de dominio pierde el acceso al proveedor de entidades corporativas y a los servidores de almacenamiento del grupo.

Solución o solución alternativa

Portal for ArcGIS se configura de manera predeterminada para actualizar el proveedor de entidades corporativas y el almacenamiento del grupo a intervalos de 24 horas, así como cuando el usuario inicia sesión. De esta forma se restablece el acceso a estos servidores y se resuelve el problema.

Para eludir el intervalo de actualización predeterminado, se pueden utilizar las siguientes soluciones:

  • Obligue a Portal for ArcGIS a que actualice el proveedor de entidades corporativas y el almacenamiento de grupo a través del extremo portaladmin.
  • Obligue a Portal for ArcGIS a que actualice el proveedor de entidades corporativas y el almacenamiento de grupo a través de ArcGIS API for Python.
  • Reconfigure Portal for ArcGIS para actualizar el proveedor de entidades corporativas y el almacenamiento de grupo a intervalos más cortos.

Obligar a Portal for ArcGIS a que actualice el proveedor de entidades corporativas y el almacenamiento de grupo a través del extremo portaladmin

  1. Inicie sesión en el extremo portaladmin de Portal for ArcGIS.
  2. Vaya a Seguridad > Grupos > Actualizar pertenencia.
  3. Introduzca todos los nombres de grupo utilizando comas para separarlos. Haga clic en Actualizar pertenencia.
Image of the Refresh Group Membership page in the Portal for ArcGIS portaladmin directory
Nota:
La actualización de la pertenencia a grupos puede tardar en realizarse en organizaciones con estructuras de grupo grandes. Para optimizar el rendimiento, actualice la pertenencia de los usuarios corporativos afectados mediante Seguridad > Usuarios > Actualizar pertenencia.

Obligar a Portal for ArcGIS a que actualice el proveedor de entidades corporativas y el almacenamiento de grupo a través de ArcGIS API for Python

  1. Inicie un compilador de Python, como Jupyter Notebook.
  2. Ejecute el siguiente script para actualizar la pertenencia a grupos:
from arcgis.gis import GIS, admin

# Sign in to Portal for ArcGIS using administrator credentials.

gis = GIS('https://', 'DOMAIN\\USERNAME', 'ADMIN PASSWORD', verify_cert=False)

groupManager = gis.admin.security.groups

# List comma-separated STRING of groups. This is a requirement of the ArcGIS REST API, and must not be a Python list.

groupList = 'GROUP1,GROUP2,GROUP3'

# This command calls the ArcGIS REST API to refresh all groups within groupList.

groupManager.refresh_groups(groupList)
  1. Para actualizar la pertenencia del usuario, también se puede ejecutar el siguiente script:
from arcgis.gis import GIS, admin

# Sign in to Portal using Portal for ArcGIS administrator credentials.

gis = GIS('https://', 'DOMAIN\\USERNAME', 'ADMIN PASSWORD', verify_cert=False)

userManager = gis.admin.security.enterpriseusers

# List comma-separated STRING of users. This is a requirement of the ArcGIS REST API, and must not be a Python list.

userList = 'user1,user2,user3'

# This command calls the ArcGIS REST API to refresh all users within userList.

userManager.refresh_users(userList)

Reconfigurar Portal for ArcGIS para actualizar el proveedor de entidades corporativas y el almacenamiento de grupo a intervalos más cortos

  1. Inicie sesión en el extremo portaladmin de Portal for ArcGIS.
  2. Vaya a Seguridad > Config > Actualizar almacén de identidad.
  3. Ajuste el parámetro membershipRefreshIntervalHours en el valor deseado. Para obtener más información sobre la configuración de los parámetros Actualizar almacén de identidad, consulte API REST de ArcGIS: Actualizar almacén de identidad.
  4. Seleccione JSON en el menú desplegable Formato y haga clic en Actualizar configuración.

Id. de artículo: 000022608

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga