PROBLEMA

ArcMap se bloquea durante la fase de lanzamiento Cargando el documento

Last Published: April 25, 2020

Descripción

ArcMap se cierra inesperadamente durante la fase "Cargando el documento..." en el inicio sin devolver ningún mensaje de error.

Causa

Esto puede ser consecuencia de una actualización a Python 2.7.11, que se publicó el 12 de diciembre de 2015.

En la versión recién publicada, hay una línea en el código con la instrucción siguiente, donde estaba 'PyWin_DLLVersionString' ahora está '2.7-32'.

Esta instrucción busca la clave de registro, que no existe:

 'HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.7-32\PythonPath'

Solución o solución alternativa

Con la publicación de Python 2.7.12, los siguientes procedimientos no son necesarios si está instalada esta versión de Python. No obstante, si no es posible actualizar a la versión 2.7.12 y está instalada la versión 2.7.11, las alternativas enumeradas a continuación siguen siendo opciones válidas.

Advertencia: 
Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Esri recomienda a los usuarios realizar una copia de seguridad de su sistema operativo y los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado. 

Esri no puede garantizar el resultado de las modificaciones incorrectas al seguir estas instrucciones; por tanto, extreme las precauciones antes de continuar.

Solución 1

  1. Haga clic en Inicio > Ejecutar, y escriba regedit. Vaya a
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.7
  1. Haga clic con el botón derecho del ratón en la carpeta 2.7 y seleccione Cambiar nombre. Cambie el nombre de la carpeta de ‘2.7’ a '2.7-32'.
  2. Cuando se haya finalizado, la ruta debe ser como la siguiente:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.7-32
  1. Cierre el Editor de registro y abra ArcMap.

Solución 2

  1. Abra el panel de control de Windows
  2. Desinstale Python 2.7.11 del sistema.
  3. Seleccione ArcGIS for Desktop Y haga clic en Desinstalar/Cambiar.
  4. Seleccione Modificar.
  5. Haga clic en la flecha desplegable situada junto a Python y seleccione la opción X Este componente no estará disponible.
  6. Permita que el instalador quite Python de la instalación de ArcGIS Desktop.
  7. Una vez que se hayan completado los pasos anteriores, seleccione de nuevo ArcGIS for Desktop y haga clic en Desinstalar/cambiar.
  8. Seleccione Modificar.
  9. Haga clic en la flecha desplegable situada junto a Python y seleccione la opción Este componente se instalará en el disco duro local.
  10. Permita que el instalador reinstale Python de la instalación de ArcGIS Desktop.

Solución 3

  1. Abra el panel de control de Windows
  2. Desinstale Python 2.7.11.
  3. Desinstale ArcGIS for Desktop.
  4. Reinstale ArcGIS for Desktop.

Id. de artículo: 000012670

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga