PROBLEMA

Se produjo un error al actualizar ArcGIS Survey123 a la versión 3.12 en un dispositivo Android

Last Published: April 27, 2022

Descripción

Google Play Store ha implementado requisitos para mejorar la seguridad de los datos utilizados por las aplicaciones almacenados en los dispositivos. Anteriormente, las aplicaciones instaladas tenían acceso al almacenamiento "público" y al almacenamiento "privado" específico de la aplicación en el dispositivo. En términos de desarrollador de Android, estos se denominan almacenamiento "externo" y "con ámbito", respectivamente. Ahora se requiere que las aplicaciones almacenen todos los datos en el almacenamiento con ámbito (privado).

La versión 3.12 de ArcGIS Survey123 incluye un proceso de migración automático que se inicia al abrir la aplicación por primera vez. Este proceso migra los datos originales de 3.11, incluidas las encuestas y la configuración del usuario, al almacenamiento con ámbito. En algunos casos, la migración falla y se devuelve un código de error.

Causa

Existen varias razones por las que falla la migración de almacenamiento Android. Consulte la lista de códigos de error y sus descripciones a continuación.

Solución o solución alternativa

Para cada código de error, consulte los pasos de resolución en la tabla siguiente.

Como parte del proceso de migración, Survey123 escribe un archivo de registro llamado "migration.log" en la carpeta de ArcGIS original del dispositivo Android (que se encuentra normalmente en /Almacenamiento interno/ArcGIS, /sdcard/ArcGIS, /storage/emulated/0/ArcGIS o similar).

Nota: Si el problema no se resuelve mediante los pasos de resolución, conserve una copia del archivo de registro y contacte con el Servicio de soporte de Esri para obtener más ayuda.
CódigoDescripciónPasos de resolución
2900Excepción de la aplicación debido a un error desconocidoProporcione una copia del archivo de registro y póngase en contacto con el Soporte técnico de Esri para obtener más ayuda.
2901Se rechazó el permiso de acceso al almacenamiento. El usuario ha denegado el acceso de la aplicación al dispositivo de almacenamiento.Reinicie la aplicación. Aparece un cuadro de diálogo que solicita permiso para acceder al dispositivo de almacenamiento. Se debe conceder permiso para que la migración pueda continuar.
2902La carpeta de datos de ArcGIS no se encuentra en el almacenamiento heredadoConsulte el mensaje de error en el archivo de registro para conocer la ruta esperada a la carpeta heredada de ArcGIS. Confirme que esta carpeta existe en esta ubicación.
2903La verificación falló porque el archivo no existe en la ubicación de destinoConsulte el mensaje de error en el archivo de registro para conocer el archivo esperado no encontrado en la nueva ubicación de almacenamiento. 
2904La verificación falló porque los tamaños de archivo no son igualesConsulte el mensaje de error en el archivo de registro para ver el archivo que no tiene igual tamaño en la ubicación de almacenamiento antigua y nueva.
2905El dispositivo de almacenamiento no tiene suficiente espacio libreConsulte el mensaje de error en el archivo de registro para ver el espacio total del dispositivo de almacenamiento, el espacio libre disponible y el tamaño de las carpetas de ArcGIS que se deben copiar para la migración. El espacio mínimo requerido es dos veces el tamaño de la carpeta de ArcGIS. Libere almacenamiento manualmente en el dispositivo para permitir que se produzca la migración.
2906Error al eliminar el archivo de configuración heredadoAsegúrese de que ninguna otra instancia de Survey123 esté abierta y que ninguna otra aplicación tenga archivos o carpetas abiertos en la ubicación de almacenamiento heredada de ArcGIS. Vuelva a ejecutar la migración.
2907Error al crear la carpeta en la ubicación de destinoReinicie la aplicación. Aparecerá un cuadro de diálogo que solicita permiso para acceder al dispositivo de almacenamiento. Se debe conceder permiso para que la migración pueda continuar.
2908Error al eliminar el archivo zip existenteAsegúrese de que ninguna otra instancia de Survey123 esté abierta y que ninguna otra aplicación tenga archivos o carpetas abiertos en la ubicación de almacenamiento heredada de ArcGIS. Vuelva a ejecutar la migración.
2909Error al eliminar la carpeta del almacenamiento heredadoAsegúrese de que ninguna otra instancia de Survey123 esté abierta y que ninguna otra aplicación tenga archivos o carpetas abiertos en la ubicación de almacenamiento heredada de ArcGIS. Vuelva a ejecutar la migración.
2910La base de datos no existe en el almacenamiento con ámbito después de la migración del archivoConfirme que el archivo de la base de datos de la encuesta exista en la ubicación de almacenamiento heredada antes del proceso de migración.
2911Error al actualizar las rutas de la cartoteca en el archivo de configuraciónAsegúrese de que el archivo de configuración exista en la ubicación de almacenamiento con ámbito y que ninguna otra aplicación tenga abierto el archivo. Vuelva a ejecutar la migración.
2912Error al copiar el archivo de datos al almacenamiento con ámbitoReinicie la aplicación. Aparecerá un cuadro de diálogo que solicita permiso para acceder al dispositivo de almacenamiento. Se debe conceder permiso para que la migración pueda continuar.
2913Error al copiar el archivo de datos sobre un archivo existente en el almacenamiento con ámbitoAsegúrese de que ninguna otra instancia de Survey123 esté abierta y que ninguna otra aplicación tenga archivos o carpetas abiertos en la ubicación de almacenamiento con ámbito. Vuelva a ejecutar la migración.
2914Error al abrir el archivo de configuración para su actualizaciónAsegúrese de que el archivo de configuración exista en la ubicación de almacenamiento con ámbito y que ninguna otra aplicación tenga abierto el archivo. Vuelva a ejecutar la migración.
2915Error al actualizar rutas de dispositivos conocidasAsegúrese de que el archivo de configuración exista en la ubicación de almacenamiento con ámbito y que ninguna otra aplicación tenga abierto el archivo. Vuelva a ejecutar la migración.
2917Error al agregar el archivo al archivo zipVuelva a ejecutar la migración.
2918Error al abrir el archivo de registro para su escrituraConfirme que exista la ubicación de almacenamiento de datos heredada.
2919El archivo de configuración no existe en el almacenamiento con ámbito después de la migración del archivoConfirme que el archivo de configuración de Survey123 exista en la ubicación de almacenamiento heredada.
2920Error al leer desde el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2921Error al escribir en el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2922Error al escribir en el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2923Error al escribir en el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2924Error al escribir en el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2925Error al escribir en el almacenamiento con ámbito durante la prueba previa al vueloConfirme que exista la ubicación de almacenamiento con ámbito esperada.
2926Error al escribir el archivo zipVuelva a ejecutar la migración.

Id. de artículo: 000025129

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga