PROBLEMA

No se pueden agregar nuevos agentes de Monitor después de actualizar a ArcGIS Monitor 2023.3.1

Last Published: January 20, 2025

Descripción

Después de actualizar a ArcGIS Monitor 2023.3.1, no se pueden agregar nuevos agentes con el siguiente error:

"Failed to fetch".

imagen de error al conectarse a Monitor Server

Causa

 

Al inspeccionar el tráfico de red, se devuelve un error de "solicitud de origen cruzado bloqueada" (CORS), como se muestra en la siguiente imagen:

image001.png

Con el error CORS, vemos que la solicitud de la máquina del agente a la máquina del servidor para obtener un token está bloqueada y se produce un error en el registro debido a un error de red.

Solución o solución alternativa

Abrir la URL de administrador del sitio de Monitor en la máquina del agente y simplemente iniciar sesión permitió que el nuevo agente continuara registrándose desde otra pestaña del navegador.

  1. En la máquina del agente, abra una nueva pestaña desde el explorador y vaya a la página de administración del sitio de Monitor Server.
  2. Inicie sesión en el sitio de Monitor Server.
  3. Regrese a la pestaña para registrar el agente y haga clic en el botón Siguiente sin el error "Error al obtener".

Id. de artículo: 000032368

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga