PROBLEMA

Un conflicto con la tarjeta gráfica podría hacer que ArcMap deje de funcionar

Last Published: April 25, 2020

Descripción

ArcMap puede dejar de funcionar por varios motivos. Puede ocurrir al cargar la vista de datos, al abrirse, durante un procesamiento complejo, etc. Una de las cosas que hay que tener en cuenta cuando ArcMap deja de funcionar es la influencia de problemas externos en nuestro software y posibles causantes del bloqueo. ArcMap depende en gran media de las capacidades de las tarjetas gráficas. En Windows 7 puede realizar los pasos siguientes para localizar las tarjetas gráficas:

  1. Vaya a Inicio > Panel de control .
  2. Haga clic en Administrador de dispositivos.
Nota:
Es posible que se necesiten privilegios administrativos para ver el Administrador de dispositivos. Algunos clientes pueden tener suficientes permisos de visualización, pero no pueden realizar modificaciones.
Screenshot of Device Manager's Display adapters section
  1. Expanda el nodo Adaptadores de pantalla. Si contiene más de un elemento, el bloqueo de ArcMap puede deberse a un conflicto entre las tarjetas gráficas mostradas.

Causa

A veces un conflicto en las tarjetas gráficas puede hacer que ArcMap deje de funcionar. Esto suele ocurrir cuando un equipo tiene una tarjeta gráfica concreta, además de una tarjeta gráfica integrada (por ejemplo, Intel con AMD FirePro). Para confirmar esta situación, puede deshabilitar una tarjeta y dejar la otra activada, reiniciar el equipo y abrir ArcMap de nuevo para averiguar si el problema se ha resuelto. El usuario también puede probar a rehabilitar la primera tarjeta, a deshabilitar la segunda tarjeta y a abrir ArcMap de nuevo. Si el problema se soluciona deshabilitando una tarjeta o la otra, las tarjetas gráficas podrían ser las culpables.

Solución o solución alternativa

Aunque no corresponde a los servicios de soporte técnico de Esri solucionar los problemas relacionados con las tarjetas gráficas, se sabe que las siguientes tres soluciones permiten resolver estos problemas. Tenga en cuenta que Esri recomienda que un departamento de TI participe en estos pasos para aprobar los cambios en el equipo:

  • Una serie de pasos de deshabilitación, nueva habilitación y reinicio pueden permitir una restauración suficiente del equipo para que ArcMap pueda determinar qué tarjeta utilizar al iniciar y mostrar los datos:
  1. Deshabilite la primera tarjeta.
  2. Reinicie el equipo.
  3. Abra ArcMap.
  4. Habilite la primera tarjeta.
  5. Deshabilite la segunda tarjeta.
  6. Reinicie el equipo.
  7. Abra ArcMap.
  8. Habilite la segunda tarjeta otra vez.
  9. Reinicie el equipo.
  10. Abra ArcMap.
  • El cliente también debe asegurarse de tener la versión más reciente del controlador de la tarjeta gráfica de la empresa de hardware correspondiente.
  • Si surgen problemas con AMD FirePro , los clientes podrán configurar el AMD Catalyst Control Center para ejecutar arcmap.exe en el modo de alto rendimiento.
Screenshot showing AMD Catalyst Control Center setting arcmap.exe to High Performance

Id. de artículo: 000013717

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga