Mensaje de error
Los intentos de publicar una capa de escena web desde ArcGIS Pro fallan y aparece el siguiente mensaje de error:
Error: Su portal no admite la publicación de capas de escena web.
Causa
Portal for ArcGIS no puede conectarse al data store de caché de teselas.
Solución o solución alternativa
Vuelva a configurar el data store de caché de teselas y asegúrese de que los puertos requeridos estén abiertos en el entorno de ArcGIS Enterprise para que todos los componentes se puedan comunicar correctamente entre sí.
Advertencia: La siguiente solución elimina los datos del data store. Esri recomienda una copia de seguridad de los datos antes de continuar con estos pasos.
- Ejecute la ventana de comandos de Windows como administrador.
- Vaya a la carpeta de utilidades de ArcGIS Data Store ubicada en:
C:\Archivos de programa\ArcGIS\DataStore\tools
- Ejecute la utilidad de comando unregisterdatastore para dar de baja el data store de caché de teselas con el siguiente comando:
unregisterdatastore.bat –stores tileCache –prompt yes
- Desinstale ArcGIS Data Store. Consulte ArcGIS Enterprise: Desinstalar ArcGIS Data Store para ver los pasos para hacerlo.
- Cambie el nombre de la carpeta DataStore aDataStore_antiguo en el siguiente directorio:
C:\Archivos de programa\ArcGIS\DataStore
- Instale la versión más reciente de ArcGIS Data Store. Consulte ArcGIS Enterprise: Instalar ArcGIS Data Store para ver los pasos para hacerlo.
- Cree un data store de caché de teselas mediante el Asistente de configuración de data store. Consulte ArcGIS Enterprise: Crear un data store para ver los pasos para hacerlo.
- Abra todos los puertos requeridos para que ArcGIS Data Store se comunique con el resto de componentes de ArcGIS Enterprise. Consulte ArcGIS Enterprise: Configuración de firewall y ArcGIS Enterprise: Visualizar un diagrama de los puertos utilizados en una implementación de ArcGIS Enterprise para obtener más información.