CÓMO

No se puede iniciar sesión usando IDP. Se encontró un asunto no válido en la respuesta SAML para Shibboleth

Last Published: August 24, 2024

Descripción

Cuando se utiliza el IDP de Shibboleth, aparece el siguiente error al intentar iniciar sesión en un portal de ArcGIS Enterprise mediante inicios de sesión SAML:

Unable to login using Idp. Invalid subject found in SAML response.

Causa

El atributo SAML NameID no se encuentra en el elemento <Subject> de la respuesta de la aserción SAML.

Solución o solución alternativa

  1. Edite el archivo SHIBBOLETH_HOME/conf/saml-nameid.xml y reemplace esta sección:
<!--

<bean parent="shibboleth.SAML2AttributeSourcedGenerator"

   p:format="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"

   p:attributeSourceIds="#{ {'mail'} }" />

-->

with the following:

<bean parent="shibboleth.SAML2AttributeSourcedGenerator"

            p:format="urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"

            p:attributeSourceIds="#{ {'your-name-id-attribute'} }" />
  1. Reinicie el servicio (Windows) o el demonio de Shibboleth (Linux).

Id. de artículo: 000026099

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga