ERROR

No se pudo crear o abrir la base de datos predeterminada

Last Published: May 21, 2020

Mensaje de error

Al abrir ArcMap, aparece el siguiente mensaje de error en el inicio:

Error: No se pudo crear o abrir la base de datos predeterminada. Este error se debe a una de las siguientes condiciones: Espacio en disco insuficiente Acceso insuficiente o incorrecto a: C:\ Instalación no válida o dañada de MSXML Para obtener información adicional sobre este error y posibles resoluciones, consulte el artículo de la base de conocimiento KB38523.
Captura de pantalla del error

Causa

En ArcGIS 10.x, uno de los procesos de inicio es la creación o validación de una geodatabase de archivos predeterminada en el directorio '<User Profile>\Mis documentos\ArcGIS para el usuario que ejecuta el software. La geodatabase predeterminada se utiliza en muchas tareas en toda la aplicación y se necesita para ejecutar el software de forma eficaz.

Como resultado de una de las condiciones descritas en el mensaje de error, la geodatabase predeterminada no se puede crear ni validar correctamente y el inicio de la aplicación falla.

Solución o solución alternativa

Para evitar este problema, siga estos pasos.

  1. Asegúrese de que el software no prohíba el acceso a la geodatabase predeterminada, como firewalls o configuraciones de red privada virtual (VPN). Esri recomienda crear la geodatabase predeterminada en el equipo local. Para cambiar la ruta a la nueva geodatabase predeterminada en el equipo local, consulte Cómo: Establecer la carpeta de inicio predeterminada y la ubicación de la geodatabase para nuevos documentos de mapa para obtener más información.
  2. En el Explorador de Windows, haga clic con el botón derecho en la unidad de la nueva geodatabase predeterminada y seleccione Propiedades.
  3. Seleccione la pestaña General y asegúrese de que haya suficiente espacio disponible en la unidad. La geodatabase de archivos predeterminada no requiere más de 0,5 MB.
  4. En el Explorador de Windows, vaya al directorio de la nueva geodatabase predeterminada.
Nota: Si la carpeta contiene varias versiones del archivo Default.gdb, vaya al paso 6. Varias geodatabases predeterminadas presentan nombres únicos y siguen este formato de nombre: Default.gdb, Default1.gdb, Default2.gdb, etc. En el Explorador de Windows, las geodatabases de archivos aparecen como carpetas con el nombre de la geodatabase seguido de la extensión .gdb.
  1. Haga clic con el botón derecho en la carpeta y seleccione Propiedades.
  2. Seleccione la pestaña Seguridad y asegúrese de que el usuario que intenta ejecutar el software tenga permisos de Lectura y escritura.
  3. Si en el espacio de trabajo descrito en el paso 4 hay una o más carpetas Default.gdb, elimínelas.
  4. Cambie el nombre del archivo Default.gdb a, por ejemplo, Default_old.gdb. Se crea un nuevo archivo Default.gdb cuando se carga ArcMap.
  5. Instale MSXML 4.0 Service Pack 3 (Microsoft XML Core Services).
  6. Ejecute una reparación de software en ArcGIS Desktop. Consulte Reparar o quitar programas en Windows 10 para ver los pasos para hacerlo.
  7. Reinicie el equipo e inicie ArcMap. La aplicación se inicia correctamente.

Id. de artículo: 000011147

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