ERROR

No es posible completar la acción porque la carpeta o un archivo de la misma están abiertos en otro programa

Last Published: March 30, 2021

Mensaje de error

Una práctica habitual al intentar volver a instalar o reparar software para ArcGIS Enterprise es realizar una desinstalación completa del software. En algunos casos, el proceso de desinstalación completa de componentes de ArcGIS Enterprise como Portal for ArcGIS, ArcGIS Server y ArcGIS Data Store no se completa porque los archivos de programa no se pueden eliminar. Al intentar eliminar las carpetas de programa de los componentes del equipo local, aparece el siguiente mensaje de error:

Error: No es posible completar la acción porque la carpeta o un archivo de la misma están abiertos en otro programa
La imagen muestra el mensaje de error: No es posible completar la acción porque la carpeta o un archivo de la misma están abiertos en otro programa al intentar desinstalar el componente Data Store de ArcGIS Enterprise

Causa

Los servicios de componentes de ArcGIS Enterprise existen en los Servicios de Windows incluso después de desinstalar y eliminar del equipo los componentes relacionados.

Solución o solución alternativa

Siga el siguiente flujo de trabajo para resolver el error.

Advertencia: Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Esri recomienda realizar una copia de seguridad de su sistema operativo y los archivos, incluido el registro, antes de continuar. Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Tenga cuidado. Si es necesario, consulte a un profesional en sistemas informáticos cualificado.
  1. Cierre todas las aplicaciones de ArcGIS del equipo.
  2. Abra el menú Inicio de Windows.
  3. En la barra de búsqueda, escriba regedit y pulse Intro. Si se le pide, haga clic en en la ventana Control de cuentas de usuario.
Imagen que muestra la búsqueda de regedit en la barra de búsqueda de Windows para abrir el Editor del Registro
  1. En la ventana Editor del Registro, expanda HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services.
  2. Haga clic con el botón derecho en la carpeta ArcGIS Data Store y haga clic en Exportar para guardar una copia.
La selección de Exportar de la ventana Editor del Registro de ArcGIS Data Store
  1. Haga clic con el botón derecho en la carpeta ArcGIS Data Store y haga clic en Eliminar para eliminar la carpeta.
  2. Repita los pasos del 4 al 6 para las carpetas de ArcGIS Server y Portal for ArcGIS.
  3. Reinicie el equipo.
  4. Pruebe a eliminar las carpetas de programa de los componentes de ArcGIS Enterprise yendo a la dirección que aparece a continuación:
C:\Archivos de programa\ArcGIS\<ArcGIS Enterprise folder>
Nota: Las carpetas de ArcGIS Enterprise incluyen las carpetas ArcGIS Server, Portal for ArcGIS y ArcGIS Data Store.

Id. de artículo: 000025029

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga