ERROR

Falta un parámetro o el parámetro no es válido

Last Published: December 9, 2021

Mensaje de error

Al intentar ejecutar la herramienta Crear geodatabase corporativa o Habilitar geodatabase corporativa en ArcGIS Pro, aparece el siguiente mensaje de error:

Error: 
Falta un parámetro o el parámetro no es válido.

Causa

Si todos los parámetros de entrada se han rellenado correctamente, pero el error persiste, puede deberse a que la herramienta no reconoce el archivo de autorización utilizado actualmente (keycodes.ecp) o a que el archivo no es válido.

Solución o solución alternativa

Vuelva a generar el archivo de autorización mediante el asistente Autorización de software. Siga los pasos a continuación:

  1. Abra el asistente de Autorización de software (SoftwareAuthorization.exe) en la siguiente ruta de la carpeta:
    C:\Archivos de programa (x86)\Common Files\ArcGIS\bin
  2. En la ventana Asistente Autorización de software, en Opciones de autorización, seleccione He instalado mi software y necesito autorizarlo.
  3. En Producto para autorizar, seleccione ArcGIS Server.
  4. En Método de autorización, seleccione Autorizar con Esri ahora mediante Internet.
  5. Rellene la información necesaria y haga clic en Siguiente.
  6. Rellene la información de la organización y haga clic en Siguiente.
  7. En Número de autorización de software de ArcGIS for Server, introduzca el número ECP recibido de la información de autorización corporativa de ArcGIS for Server en My Esri.
  8. En Opciones, seleccione No deseo autorizar ninguna extensión en este momento y haga clic en Siguiente.
  9. No active ninguna casilla y haga clic en Siguiente.
  10. Una vez completado, compruebe el archivo de códigos clave generado en el siguiente directorio:
    C:\Archivos de programa (x86)\Esri\License10.x\sysgen
  11. Cree una copia del archivo e incorpore la extensión .ecp al nombre de archivo. El icono se cambia a una imagen de una llave para el formato de archivo de protección contra copias ECP. Utilice el archivo para volver a autorizar la base de datos.

Id. de artículo: 000019028

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga