ERROR

Error al cargar las herramientas del sistema

Last Published: December 29, 2020

Mensaje de error

En ArcGIS Pro, al intentar abrir el panel Geoprocesamiento, aparece el siguiente error:

Error: Error al cargar las herramientas del sistema.

En algunos casos, el error va seguido de un error de trazado inverso de Python que hace referencia a un módulo que no se puede importar, como se muestra en la siguiente imagen.

Imagen del error de trazado inverso de Python

Causa

El error está relacionado con el entorno de proyecto de Python que utiliza ArcGIS Pro. Esto podría deberse a una falta de coincidencia en el archivo proenv.txt, una memoria caché completa o una instalación dañada de ArcGIS Pro.

Solución o solución alternativa

Este error se puede resolver realizando una de las soluciones enumeradas a continuación, modificando el archivo proenv.txt o borrando los archivos almacenados en caché. Si el problema persiste, continúe con la solución posterior, volviendo a instalar ArcGIS Pro.

Modificar el archivo proenv.txt para que coincida con el entorno especificado en ArcGIS Pro

  1. En ArcGIS Pro, vaya a Configuración > Python.
  2. Tome nota del entorno del proyecto activo. En este ejemplo, el entorno activo en ArcGIS Pro es arcgispro-py3.
Imagen que muestra el entorno del proyecto de Python en ArcGIS Pro.
  1. Vaya a la siguiente ubicación de carpeta:
C:\Archivos de programa\ArcGIS\Pro\bin\Python\Scripts
  1. Abra el archivo proenv.txt en un editor de texto.
  2. Verifique que el entorno activo de ArcGIS Pro coincida con el entorno que aparece en este archivo de texto. Si el entorno es diferente, modifique el archivo de texto para que coincida con el entorno activo de ArcGIS Pro.
  3. Guarde y cierre el archivo proenv.txt.
Imagen que muestra el archivo de texto proenv.
  1. Vuelva a iniciar ArcGIS Pro.

Borrar caché
Borre todos los archivos de caché de la carpeta AppData y vuelva a iniciar ArcGIS Pro.

C:\Usuarios\\AppData\Local\ESRI\Local Caches
Nota: La carpeta AppData es una carpeta oculta. Para mostrar carpetas ocultas, consulte Soporte técnico de Microsoft Windows: Mostrar archivos ocultos.

Reinstalar ArcGIS Pro

Advertencia: Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Esri recomienda realizar una copia de seguridad de su sistema operativo y los archivos, incluido el registro, antes de continuar. Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Tenga cuidado. Si es necesario, consulte a un profesional en sistemas informáticos cualificado.

Realice una desinstalación limpia haciendo referencia a Esri Belux: Limpiar desinstalación de ArcGIS Pro. Después de realizar una desinstalación limpia, vuelva a instalar ArcGIS Pro según las instrucciones de ArcGIS Pro: Instalar ArcGIS Pro.

Id. de artículo:000022262

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga