ERROR

Error 1325. EsriPyFldr no es un nombre corto de archivo válido

Last Published: January 25, 2022

Mensaje de error

Al intentar desinstalar, actualizar o instalar otra versión de ArcGIS for Desktop (después de desinstalar una versión anterior), se produce un error y aparece el siguiente error:

Error 1325. EsriPyFldr no es un nombre corto de archivo válido.
Imagen del error 1325

Causa

El problema puede ocurrir debido a las carpetas de instalación de ArcGIS dañadas en ArcGIS for Desktop.Las carpetas residuales no se han eliminado y se dejan en el registro sin estar vinculadas a ninguna otra carpeta. El resultado es una desinstalación incompleta.Por lo tanto, la reinstalación de otra versión de ArcGIS for Desktop devuelve el error.

Solución o solución alternativa

Desinstale correctamente ArcGIS for Desktop antes de instalar la nueva versión. Para obtener más información sobre la instalación o desinstalación de ArcGIS for Desktop, consulte el siguiente documento de ayuda en la web, Ayuda de ArcGIS for Desktop: Desinstalación de ArcGIS for Desktop.

Siga estos pasos para garantizar una desinstalación correcta de ArcGIS for Desktop:

  1. En el Explorador de Windows, navegue hasta C:\Archivos de programa (x86) y elimine la carpeta ArcGIS.
  2. Cambie el nombre de todas las carpetas de ArcGIS y Esri de las siguientes ubicaciones:
  • C:\Archivos de programa (x86)
  • C:\Archivos de programa (x86)\Archivos comunes
  • C:\Archivos de programa
  • C:\Archivos de programa\Archivos comunes
  • C:\Program Data
  • C:\Usuarios\<user name>\AppData\Local\
  • C:\Usuarios\<user name>\AppData\Roaming
  1. Vaya al Registro de Windows; haga clic en Inicio > Ejecutar. En el cuadro de diálogo Ejecutar , escriba regedit y pulse la tecla Intro.
Advertencia: Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Se recomienda que realice una copia de seguridad del sistema operativo y de los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado. Esri no puede garantizar los resultados derivados de modificaciones incorrectas al seguir estas instrucciones; por tanto, tenga cuidado y continúe bajo su propio riesgo.
  1. Vaya a [HKEY_LOCAL_MACHINE\SOFTWARE] y elimine la carpeta Esri.
  2. Vaya a [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node] y elimine la carpeta de Esri.
  3. Actualice el equipo y ejecute el software de instalación.
Nota: La carpeta AppData es una carpeta oculta. Para mostrar las carpetas ocultas, consulte Ayuda de Windows: Mostrar archivos ocultos.
Nota: En una situación en la que se realiza una instalación limpia y el problema persiste, el problema puede ser causado por el sistema operativo Windows instalado en el equipo.Consulte el siguiente vínculo de Microsoft para solucionar el problema: Ayuda de Microsoft: Corregir problemas que impiden que los programas se instalen o se eliminen.

Id. de artículo: 000013304

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga