ERROR

ArcGISIndexingServer ha dejado de funcionar

Last Published: April 25, 2020

Mensaje de error

Si ArcGIS Pro está instalado, es posible que los usuarios se encuentren con el siguiente error:

Error:
ArcGISIndexingServer ha dejado de funcionar
Screenshot of the error.

Este error puede producirse aleatoriamente, incluso aunque ArcGIS Pro no se esté ejecutando.

Causa

De forma predeterminada, ArcGIS Pro crea automáticamente y actualiza dinámicamente un índice que permite búsquedas a medida que los usuarios trabajan con proyectos. Elementos tales como conexiones a carpetas, bases de datos y cajas de herramientas se actualizan en el índice al agregarlos a un proyecto. Para obtener más información sobre los elementos, consulte la siguiente documentación: Tipos de datos y elementos admitidos.

En función del tamaño del proyecto y de la cantidad de elementos indexados, el tamaño del índice puede superar la memoria disponible, por lo que se devuelve un error.

Solución o solución alternativa

Para impedir este error, elimine el índice existente o desactive la indexación con uno de los siguientes métodos. Algunos métodos requieren la modificación de los ajustes de Windows, por lo que hay que realizar una copia de seguridad del sistema operativo y los archivos.

  • Elimine el índice
  1. En el menú Proyecto, abra el cuadro de diálogo Opciones.
  2. Haga clic en la pestaña Indexar.
  3. Haga clic en Eliminar índice.
  4. Haga clic en Aceptar.
  • Desactive la indexación
Advertencia:
Las instrucciones que se indican a continuación incluyen hacer cambios en partes fundamentales del sistema operativo. Se recomienda realizar una copia de seguridad del sistema operativo y los archivos, incluido el registro, antes de continuar. Si es necesario, consulte con un profesional en sistemas informáticos cualificado.

Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Por tanto, utilícelos asumiendo el riesgo correspondiente.
  1. En el menú Proyecto, abra el cuadro de diálogo Opciones.
  2. Haga clic en la pestaña Indexar.
  3. En Configurar creación y modo de uso del índice, haga clic en No crear índice.
  4. Haga clic en Aceptar.
  • Deshabilite ArcGISIndexingServer.exe en Windows 7
Nota:
Para obtener instrucciones sobre versiones más recientes de Windows, consulte la documentación de ayuda de Microsoft.
  1. Haga clic en el botón Iniciar.
  2. Haga clic en Panel de control > Sistema y mantenimiento > Herramientas administrativas.
  3. Haga doble clic en Programador de tareas.
  4. Haga clic en Biblioteca del Programador de tareas y seleccione Indexación de ArcGIS Pro.
  5. En el panel Acciones, haga clic en Deshabilitar.
  • Cambie el nombre a la carpeta Índice
    Cambie el nombre a la carpeta Índice en Windows, para que ArcGIS Pro genere una nueva carpeta de índice.
  1. Abra el Explorador de Windows y vaya a C:\Usuarios\\AppData\Local\ESRI\.
  2. Cambie el nombre a la carpeta Índice.

Id. de artículo: 000016984

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga