ERROR

Se intentó establecer la conexión con una versión anterior del software de comunicaciones del cliente de SQL Server que no es compatible con el servidor de base de datos de SQL Server

Last Published: November 18, 2021

Mensaje de error

Conectar desde ArcGIS Desktop, ArcGIS Pro o desde otro cliente de ArcGIS con una geodatabase corporativa creada en SQL Server devuelve los siguientes mensajes de error:

Error de conexión: Se intentó establecer la conexión con una versión anterior del software de comunicaciones del cliente de SQL Server que no es compatible con el servidor de base de datos de SQL Server.
Error de conexión: No se puede obtener la lista de la base de datos. Se ha producido una excepción de conexión de base de datos. No se puede conectar al servidor de la base de datos para recuperar la lista de base de datos; verifique la información de su nombre de servidor, nombre de usuario y contraseña y pruébelo de nuevo. Se intentó establecer la conexión con una versión anterior del software de comunicaciones del cliente de SQL Server que no es compatible.

Causa

Estos errores pueden producirse si los controladores cliente de SQL Server no están instalados en el equipo o si la versión de los controladores utilizados no es compatible con la versión de SQL Server a la que se conecta el usuario. Los controladores deben tener la misma versión que SQL Server u otra más reciente. Por ejemplo, Microsoft ODBC Driver 17 para SQL Server es compatible con SQL Server 2019 y se debe usar al conectarse a una instancia de SQL Server 2019 desde ArcGIS.

Aunque los controladores ODBC y el cliente nativo de SQL Server suelen ser compatibles con versiones anteriores, no necesariamente son compatibles con las versiones posteriores. No hay ninguna garantía de que los clientes antiguos o no compatibles puedan funcionar sin problema. Al actualizar el entorno, también se deben actualizar los controladores del cliente de SQL Server. Se hace así para garantizar que se admita la funcionalidad más reciente introducida en ArcGIS.

Solución o solución alternativa

Verifique que haya un controlador instalado en el equipo cliente. Si lo hay, asegúrese de que se esté conectando a la misma versión que SQL Server o a otra más reciente.

Tanto los controladores ODBC de Microsoft para SQL Server como el Cliente nativo de SQL Server se pueden descargar desde Microsoft. También se pueden encontrar copias en My Esri. Para descargar estas copias:

  1. Inicie sesión en My Esri.
  2. Vaya a Mis organizaciones > Descargas > Productos.
Pestaña Producto en My Esri
  1. Desplácese a ArcGIS Enterprise y haga clic en Ver descargas.
  2. Desplácese hasta Archivos de soporte de base de datos y haga clic en Descargar en la versión de controlador ODBC de Microsoft pertinente.
Descargue el controlador ODBC más reciente en la sección Archivos de soporte de base de datos de My Esri.

La versión del archivo cliente que se va a instalar depende de la versión de SQL Server. Consulte ArcGIS Desktop: Requisitos de la base de datos de Microsoft SQL Server para ArcGIS 10.8.x y ArcGIS Pro 2.5, 2.6 y 2.7 para obtener una lista completa y actual de las versiones de bases de datos, los sistemas operativos y el software que son compatibles y necesarios para conectarse a SQL Server.

Id. de artículo: 000010759

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga