PROBLEMA

ArcGIS Pro deja de funcionar al iniciarse cuando se instala con App Layering y se agrega a Citrix XenDesktop o XenApps

Last Published: May 3, 2024

Descripción

A per-machine installation of ArcGIS Pro also installs the FlexNet Licensing Service, a necessary component for the application to obtain licensing information. Without this, ArcGIS Pro cannot obtain a single-use or borrowed concurrent-use license and, therefore, may not start. Additionally, ArcGIS Pro may crash upon startup when making a call to a corrupt FlexNet Licensing Service. ArcGIS Pro may also crash if it does not have sufficient permission to access the service.

Causa

ArcGIS Pro may crash under the following conditions:

  • The FlexNet Licensing Service is corrupted. This is an extremely rare situation which may be the result of the service having been intentionally or unintentionally edited, a corrupt system, an unforeseen installation issue, etc. 
  • ArcGIS Pro does not have sufficient access to the FlexNet Licensing Service. This may be caused by executing the application with a non-standard user type, or an application streaming framework. Consider the following example:

When using App Layering to add ArcGIS Pro to a supported version of Citrix XenDesktop or XenApps, the application may fail upon startup if run by a user with non-administrative access. A user with administrative access does not experience the failure in the same environment. If installed within XenDesktop or XenApps without App Layering, ArcGIS Pro does not crash, even when run by a user without elevated permission. An additional permission to the FlexNet Licensing Service is required.

Solución o solución alternativa

In addition to installing ArcGIS Pro, the administrator must also run a command line installation of the FlexNet Licensing Service with the parameter, MODIFYFLEXDACL=TRUE.
For example:

msiexec /I "C:\Program Files\ArcGIS\Pro\Resources\ArcGIS Licensing Service\ArcGISLS.msi" MODIFYFLEXDACL=TRUE

The installation replaces the existing, potentially corrupt service and provides the necessary additional permission to the FlexNet Licensing Service.

Id. de artículo: 000023466

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga