PROBLEMA

ArcGIS StoryMaps deja de responder y no se carga cuando se abre desde el selector de aplicaciones de Portal for ArcGIS

Last Published: March 24, 2021

Descripción

Este problema puede producirse después de actualizar de ArcGIS Enterprise 10.6.1 a 10.8.1.ArcGIS StoryMaps deja de responder y no se carga cuando se abre desde el selector de aplicaciones de Portal for ArcGIS.
 

Causa

Cuando se compara con un entorno de trabajo, hay algunas barras diagonales adicionales (/) en algunas líneas del archivo config.json de StoryMap.

Este archivo se encuentra en:

C:\Archivos de programa\ArcGIS\Portal\apps\storymaps\static\config.json

Solución o solución alternativa

  1. Después de realizar una instantánea, actualice el archivo eliminando las barras diagonales adicionales de tres líneas del archivo de configuración de story map, como se muestra en la siguiente imagen.
  2. Vaya a: C:\Archivos de programa\ArcGIS\Portal\apps\storymaps\static\config.json y abra el archivo en un editor de texto, por ejemplo, Notepad ++.

Archivo config.json

  1. En la imagen de arriba del archivo de configuración, las líneas 26, 27 y 28 tienen una barra diagonal extra resaltada en la URL (/) después de portal. Estas son las que se deben eliminar.
    Por ejemplo, en la línea 26, vemos:
"ARSGIS_JS_API_URL": "https://<domain>/portal//jsapi/jsapi4/",
  1. Después de eliminar las barras diagonales adicionales, guarde el archivo de configuración.
  2. Ahora se debería poder iniciar ArcGIS StoryMaps desde el selector de aplicaciones, a menos que haya otros problemas subyacentes en la implementación.

Id. de artículo: 000024953

Recibir notificaciones y encontrar soluciones a problemas nuevos o comunes

Obtenga respuestas resumidas y soluciones de vídeo de nuestro nuevo chatbot de IA.

Descargar la aplicación de soporte de Esri

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Descargar la aplicación de soporte de Esri

Ir a opciones de descarga