CÓMO

Los registros de ArcGIS Server informan de mensajes graves cada hora que indican un error de inicialización del procesador de webhooks

Last Published: October 25, 2024

Descripción

Note:
This issue was fixed in ArcGIS Enterprise 11.3.

Después de actualizar ArcGIS Enterprise a la versión 11.2 desde la 11.0 u 11.1, se observan mensajes de registro graves de ArcGIS Server cada hora, acerca de que el procesador de webhooks no se inicializa o no se inicia.

Ejemplos de mensajes de registro:

Estos mensajes aparecen aproximadamente cada hora:

Severe - Webhook log: Error in Webhook Processor. init WebhookProcessors failed. FS Webhook processor init failed Connecting to queue : 20839fac-4d87-4737-8df7-3c264dc8aff3_FS_Raw_Events_Queue failed. Could not create a queue with id : [20839fac-4d87-4737-8df7-3c264dc8aff3_FS_Raw_Events_Queue] Connection refused: connect.

El siguiente mensaje solo se publicará una vez, inmediatamente después de que se haya completado la actualización:

Severe - Failed to configure queue store. C:\Program Files\ArcGIS\DataStore\framework\runtime\rabbitmq\erl-24.2\bin\erl.ini (The system cannot find the path specified)
Note: 
This scenario does not impact Organization (portal) webhooks.

Causa

El almacén de colas, un componente necesario para que funcionen los webhooks de servicio, no se ha iniciado correctamente después de actualizar a la versión 11.2. El procesador de webhooks de ArcGIS Server no se conecta e intenta repararse automáticamente, lo que genera mensajes de registro cada hora.

Solución o solución alternativa

Si los webhooks de servicio no se utilizan en ArcGIS Enterprise, el procesador de webhooks se puede deshabilitar mediante los siguientes pasos, lo que evita estos mensajes de registro graves.

  1. En el Directorio del administrador de ArcGIS, vaya a Sistema. Por ejemplo: 
https://server.com/webadaptor/admin/system
  1. Vaya a Propiedades. Por ejemplo:
https://server.com/webadaptor/admin/system/properties
  1. Haga clic en Actualizar.
  2. Introduzca el siguiente JSON, entre llaves, { }, o agregue este par de claves si las propiedades de contenido ya están presentes:
{"isWebhooksEnabled":false}
  1. Reinicie ArcGIS Server.

Si su organización requiere que los webhooks de servicio sigan funcionando, póngase en contacto con el Soporte técnico de Esri para analizar otras soluciones.

Id. de artículo: 000031943

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga