PROBLEM

Unable to view Survey123 feature services in Map Viewer and error "Accessing Data Failed" returned when viewing attribute tables

Last Published: April 16, 2024

Description

When a new ArcGIS Survey123 feature service is created, the data is not visible in the ArcGIS Online Map Viewer. When trying to view the data in the Attribute table, the following error is returned:

Error: 
Accessing data failed
Error: Accessing data failed

Cause

This was an intentional change made with the 3.14 version of Survey123. Unless the Inbox is enabled or editing Sent surveys is enabled on initial publish, Survey123 Connect disables query on the feature services. This was done to provide users with the most secure data implementation and allow them to open their data up as they see fit.

The consequence is the setting under 'What features can editors see?' is set to 'Editors can't see any features, even those they add' by default, as shown in the image below.

Editor Permissions

In the past, users were publishing surveys from Survey123 Connect and immediately sharing them publicly not knowing that their data was open to the public for querying. With the current implementation, users must make the decision on how their data is shared and who has access to it.

This is included in the documentation with a workflow to resolve the issue. Refer to ArcGIS Survey123: Known issues for more information.

Solution or Workaround

Modify the setting under the What features can editors see? section as required.

Article ID:000028133

Software:
  • ArcGIS Survey123 Connect

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic