PROBLEM

The Swipe tool does not work in ArcGIS Instant Apps

Last Published: May 20, 2022

Description

The Swipe tool allows users to compare maps and data by interacting with two web maps or layers at the same time in a single scalable view. In some instances, the Swipe tool does not work in the ArcGIS Instant Apps apps such as Media Map or Imagery Viewer.

The image below shows there are no changes can be seen in the map when dragging the Swipe tool across the layers.

The image of an example of how there are no changes can be seen in the map when dragging the Swipe tool across the layers.

Cause

  • All layers are checked in both the leading and trailing layers selection section.
  • There is a corrupted layer in the web map.
Note:
It is a known limitation that the Imagery Viewer app does not honor the transparency settings for a trailing layer when the Swipe tool is enabled in ArcGIS Instant Apps. Refer to BUG-000141444 for more information.

Solution or Workaround

Use one of the methods below to resolve the issue.

Ensure the correct layers are selected

In ArcGIS Instant Apps, select the correct leading and trailing layers before publishing the app. Ensure the required layers are not selected on both layers.

In this example, the layer named Feature Collection Layer is not selected in the trailing layers list to make a comparison between the before and after wildfire accidents in Montana.

The image of the Feature Collection Layer layer is not selected in the trailing layers list to make a comparison between the before and after wildfire accidents in Montana.

Remove the corrupted layer

In ArcGIS Instant Apps, open the web map in ArcGIS Online Map Viewer. Remove the corrupted layer and add a new layer. Save the web map and refresh ArcGIS Instant Apps.

Article ID:000027691

Software:
  • ArcGIS Online
  • Configurable Web Apps

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic