PROBLEM

The Apps button is unavailable in Portal for ArcGIS

Last Published: July 23, 2021

Description

In Portal for ArcGIS, apps can be accessed from the app launcher via the Apps button in the portal home page. In some instances, the Apps button is unavailable.

The App Launcher is unavailable in the Portal for ArcGIS homepage

Cause

Upgrading to a new version of Portal for ArcGIS may cause the portal index to be incomplete. When the portal index is incomplete, apps, groups, items and users are not displayed correctly.

Solution or Workaround

Note:
The following procedure can only be performed by an administrator account.

Reindex the portal. Follow these steps to do so.

  1. Access the Portal Administrator directory and log in with an account that has administrator privileges. The format of the Portal Administrator directory is as follows:
https://portal.domain.com:7443/arcgis/portaladmin
  1. Navigate to System > Indexer > Reindex.
  2. Click the Mode drop-down list and select Full.
  3. Click Reindex to rebuild the portal's index. The Apps button is now available.
The Reindex dialog box in the Portal Administrator Directory Reindex page set to Full mode and clicking the Reindex button

Article ID:000026062

Software:
  • Portal for ArcGIS

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