PROBLEM

Choices are unavailable for a question in a survey created in ArcGIS Survey123 Connect 3.12 if the choice filter column contains keywords

Last Published: April 27, 2022

Description

When creating a survey in ArcGIS Survey123 Connect 3.12, if a question uses the choice filter column with certain keywords in the survey sheet, for example 'group', the question is unable to select choices from the column with the same keyword in the choices sheet.

In this example, both questions of the survey use the choice filter column, with the first containing choices from the 'GROUPING' column, and the second containing choices from the 'GROUP' column in the choices sheet.

The XLSForm of the survey showing one question using the GROUPING column and the GROUP column in the choice filter

When previewing the survey, the choices are available for the question using the 'GROUPING' column, but is unavailable for the question using the 'GROUP' column.

A preview of the survey showing the choices are not available for the question using the GROUP column in the choice filter compared with the question using the GROUPING column

Cause

The name used in the choice filter column of the survey sheet and corresponding column in the choice sheet is a reserved SQL keyword. In this instance, the reserved SQL keyword is 'GROUP'. This is a known limitation for ArcGIS Survey123 Connect 3.12 that uses a database approach for managing choice lists.

Solution or Workaround

Avoid using reserved SQL keywords in the choice filter column. Refer to SQLite: SQLite Keywords for more information on reserved keywords. As a workaround, use similar words that are not the SQL keywords, for example, 'grouping' instead of 'group', or 'ordering' instead of 'order'.

Article ID:000025216

Software:
  • ArcGIS Online
  • ArcGIS Survey123 Connect

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic