ERROR

The survey does not exist or is not accessible

Last Published: April 27, 2022

Error Message

Attempts to sign in to the ArcGIS Survey123 website with a Portal for ArcGIS URL affixed fail, returning the following error message:

Error:   
The survey does not exist or is not accessible.
The error message 'The survey does not exist or is not accessible'.

Additionally, the following error is appended to the URL of the site:

Error:   
error?errorCode=survey11

The browser's developer tools console displays the following error:

Error:   
error?errorCode=survey11:1 Access to XMLHttpRequest at 'https://machineName.domain.com/portal/sharing/rest/generateToken?f=json' from origin 'https://survey123.arcgis.com' has been blocked by CORS policy: The 'Access-Control-Allow-Origin' header contains multiple values 'https://survey123.arcgis.com, *', but only one is allowed.

Cause

Duplicate headers are configured in Internet Information Services (IIS) Manager.

Solution or Workaround

Remove the duplicate headers in IIS Manager.

Note:
Completing this workaround may require assistance from the organization's IT department.
  1. Launch IIS Manager.
  2. In the Connections pane, expand the machine name.
  3. Expand the Sites folder.
  4. Select Default Web Site, and open HTTP Response Headers. Compare the values with the headers for the portal and server web adaptors.
  5. Remove all the duplicate headers from the web adaptors.

Article ID:000024873

Software:
  • Portal for ArcGIS
  • ArcGIS Survey123 Website

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