ERROR

Attempt to configure data store failed. No valid connection to ArcGIS Data Store configuration store established

Last Published: March 25, 2021

Error Message

When attempting to upgrade ArcGIS Data Store to version 10.8.1, the upgrade may fail and return the following error message:

Error:   
Attempt to configure data store failed. Caused by: No valid connection to ArcGIS Data Store configuration store established. FATAL: password authentication failed for user.

This occurs even though the administrative account used is listed in the data store administrator list.

Cause

  • The password for the internal data store administrator is lost. There is no known cause for this occurrence.
  • The firewall settings on the data store machine are preventing the program from running properly.
  • The ArcGIS Data Store ports are not listening.
  • The antivirus software is blocking back-end processes.

Solution or Workaround

To resolve the issue, perform any of the workarounds below depending on the cause.

Change the Windows Defender Firewall settings

Change the firewall settings to allow the software to complete the upgrade process. For more information on creating inbound and outbound rules for a Windows firewall, refer to Microsoft: Create an Inbound Program or Service Rule and Microsoft: Create an Outbound Program or Service Rule.

Open the ArcGIS Data Store ports to allow listening

Open the ArcGIS Data Store ports to allow ArcGIS Data Store to communicate with other parts of ArcGIS Enterprise. For more information on opening ports, refer to Microsoft: Create an Inbound Port Rule and Microsoft: Create an Outbound Port Rule.

Note:
For a list of all ports used by ArcGIS Data Store, refer to ArcGIS Enterprise: Ports used by ArcGIS Data Store.

Create exceptions in the antivirus software for ArcGIS Data Store

Create exceptions in the antivirus software to allow ArcGIS Data Store to complete tasks. Refer to the Esri documentation, Considerations for configuring antivirus software for ArcGIS Enterprise hosts for information on best practices regarding antivirus software in ArcGIS Enterprise deployments, directories to exclude from virus scanning, and other considerations.

Note:
If the workarounds above do not resolve the issue, restore the data store with available backup files. For instructions, refer to Portal for ArcGIS: Recover a data store.

If the restoredatastore utility fails, contact Esri Technical Support for further assistance.

Article ID:000024633

Software:
  • ArcGIS Data Store

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