Description
In ArcGIS Online or Portal for ArcGIS, when configuring the logo of an ArcGIS Web AppBuilder app, the ‘Organization shared’ option is checked, but the logo is not displayed, or the app logo displays as a broken image.
The image below shows the organization shared logo is unavailable.
The image below shows the app logo displays as a broken image.
Cause
The known causes for this issue are as follows:
- No logo is uploaded in the organization’s Shared Theme setting in ArcGIS Online or Portal for ArcGIS.
- The Shared Theme logo has been set to private.
- The Shared Theme logo has been deleted in My Content.
Solution or Workaround
Depending on the cause, use one of the options below to resolve the issue.
Note:
Only administrators can perform the following workflows.
Upload the logo in the organization’s Shared Theme setting
In ArcGIS Online
- Log in to ArcGIS Online. Click Organization > Settings > General > Shared theme.
- In the Logo section, click Upload image.
- In the Upload logo window, drag and drop the desired image, or click Browse to open the image.
- Slide the handle of the Zoom slider to set the size for the logo, and click Save to upload the logo.
Note:
The Shared Theme logo is automatically rendered in newly created ArcGIS Web AppBuilder apps.
- For an existing ArcGIS Web AppBuilder app, on the Attribute tab, hover over the app logo, and select Organization shared to use the uploaded Shared Theme logo.
In Portal for ArcGIS
- Log in to Portal for ArcGIS. Click Organization > Settings > General.
- Scroll to the Shared Theme section. In the Logo Image section, click Upload Logo to upload the Shared Theme logo.
- Scroll to the top, and click Save in the top-left corner.
Note:
The Shared Theme logo is automatically rendered in newly created ArcGIS Web AppBuilder apps.
- For an existing ArcGIS Web AppBuilder app, on the Attribute tab, hover over the app logo, and select Organization shared to use the uploaded Shared Theme logo.
Share the organization’s Shared Theme logo with the public
- Log in to ArcGIS Online or Portal for ArcGIS. Click Content > My Content.
- Browse to the Shared Theme logo - <image_name> image, and share the image publicly. Refer to ArcGIS Online: Share items with everyone for more information.
Note:
It is not possible to recover a deleted item in ArcGIS Online or Portal for ArcGIS. A preventive measure is to enable the ‘Delete Protection’ setting for the item. Refer to ArcGIS Blog: How to prevent accidental deletion for more information.