PROBLEM

Unable to view data on the Data tab in ArcGIS Online

Last Published: November 3, 2020

Description

When creating a hosted feature service in ArcGIS Online, the data does not display on the Data tab and returns the following error message:

Error:   
There was an error.

The following image shows the error message displayed on the Data tab in ArcGIS Online.

Image of the error message in the Data tab in ArcGIS Online

Cause

  • The browsing cache on the machine is not cleared.
  • The 'Create a feature layer' window is closed before the creation of the layer is complete. This interrupts the creation of the service and it is not created properly.

Solution or Workaround

Select one of the options below depending on the cause to resolve the issue.

Clear the browsing cache

Clear the browsing cache on the machine to ensure a smooth performance of the browser. Refer to Google Account Help: Clear cache & cookies for more information.

Ensure the Create a feature layer window is open until the layer creation is complete

When creating a feature layer, ensure the Create a feature layer window remains open until the creation process is complete. After it is complete, the item details page displays automatically.

Article ID:000024402

Software:
  • ArcGIS Online

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic