PROBLEM

Unable to cancel a job in ArcGIS Pro

Last Published: September 8, 2023

Description

In some instances, sharing a package in the Create Project Template or Create Vector Tile Package pane fails, and the sharing process cannot be canceled in the Job Status pane in ArcGIS Pro. Force closing ArcGIS Pro does not cancel the job as the sharing process restarts after reopening the application.

Cause

The sharing process runs in the background, allowing users to work with ArcGIS Pro. Closing ArcGIS Pro does not end the sharing process as it is a separate process from the jobs processed in ArcGIS Pro.

Solution or Workaround

If attempting to cancel the task in the Job Status pane fails and the task is still running, end the ArcGISSharingServer.exe process in Windows Task Manager by following the steps below.

Note:
The same process is listed as SharingServer DLL in some cases.
  1. On the Windows desktop, right-click the desktop taskbar, and click Start Task Manager.
  2. In Windows Task Manager, click Processes or Details, depending on OS version.
Image of the Processes tab in Windows Task Manager
  1. Click ArcGISSharingServer.exe.
  2. Click End Process or End Task, depending on OS version.
Image showing the Processes tab in Windows Tasks Manager
  1. In the Do you want to end 'ArcGISSharingServer.exe.'? dialog box, click End process.
Image of the Windows Task Manager dialog box
  1. In ArcGIS Pro, in the Job Status pane, click the Cancel icon to cancel the task.
Image of the Job Status pane

Article ID: 000024380

Software:
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options