ERROR

Critical service failed to initialize (esriAnalyst/services/variableManager)

Last Published: October 2, 2020

Error Message

Attempts to log in to ArcGIS Business Analyst fail, and return the following error message:

Error:   
Critical service failed to initialize
(esriAnalyst/services/variableManager)
Image of the Error message.

Cause

The user lacks the required permissions to access ArcGIS Business Analyst.

Solution or Workaround

Note:
Only administrators have the sufficient privileges to perform the workflow below.

To resolve the error, change the user's role to Administrator or Publisher to allow full access to ArcGIS Business Analyst. Refer to ArcGIS Online: Change member roles for steps to do so.

Alternatively, change the user's role to User or Custom, and configure it to grant the necessary privileges to allow limited access to the features and functionality in ArcGIS Business Analyst. Refer to ArcGIS Business Analyst: Permissions for more information.

Article ID:000024179

Software:
  • ArcGIS Business Analyst Web App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic