ERROR

An error occurred while loading the page. Some features may not work

Last Published: May 6, 2022

Error Message

Attempts to view the Data tab of a survey in ArcGIS Survey123 fail and return the following error message:

Error:   
An error occurred while loading the page. Some features may not work.
The error message returned in the Data tab of ArcGIS Survey123

Cause

  • The query capability of the survey's feature service is disabled. The 'Editors can't see any features, even those they add' option is enabled in the hosted feature layer setting.
  • The survey contains name fields with reserved keywords.
  • There is an existing cache in the browser disrupting the Data tab to load.

Solution or Workaround

Based the cause, the following workarounds are applicable.

The query capability of the survey's feature service is disabled
Enable the query capability of the survey in its hosted feature layer setting.
  1. Log in to ArcGIS Online.
  2. Navigate to Content > My Content > Survey_<Survey_Name>.
  3. In the survey folder, select the hosted feature layer of the survey.
  4. On the hosted feature layer item details page, click Settings.
  5. In the Feature Layer (hosted) section, under What features can editors see?, select Editors can see all features or Editors can only see their own features (requires tracking), as shown in the following image.
The 'What features can editors see' setting.
  1. Click Save.
The survey contains name fields with reserved keywords
Modify the reserved keywords that are used as the name field values in the survey XLSForm.
  1. Create a copy of the survey XLSForm.
  2. In the XLSForm, modify the reserved keyword that is used as the name field value. In this example, where is modified to where_.
The reserved keyword in the name field.
The modify the reserved keyword setting.
  1. In Survey123 Connect, create a new survey using the XLSForm file created in Step 1.
  2. Publish the survey.
Note:
Refer to the Reserved Keywords list in the types sheet of the survey XLSForm.
There is an existing cache in the browser disrupting the Data tab to load
  1. Clear the browser's cache.
  2. Refresh the ArcGIS Survey123 website page.

Article ID:000023290

Software:
  • ArcGIS Survey123 Website

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic