Error Message
Attempts to publish a survey from ArcGIS Survey123 Connect to ArcGIS Online or Portal for ArcGIS fail, and return the following error message:
Error:
Publishing failed to complete. Unable to create folder. Error code: 400
Cause
The following are possible causes for the issue:
- The survey XLSForm contains duplicate values in the name field column.
- The survey has the same name as an existing survey folder in ArcGIS Online or Portal for ArcGIS.
Solution or Workaround
Depending on the cause, use one of the options below to resolve the issue.
Modify the duplicate name field values in the survey XLSForm
- Create a copy of the survey XLSForm.
- In the XLSForm, in the survey tab, modify the duplicate values in the name column. In this example, the duplicate of installation_phase, additional_notes, and PIA_Phase are modified to installation_phase_, additional_notes1, and PIA_Phase_ respectively.
- Publish the survey from Survey123 Connect.
Note:
The values in the name column must be in lower case for surveys published to Portal for ArcGIS.
Rename or remove the folder in ArcGIS Online or Portal for ArcGIS
- Log in to ArcGIS Online or Portal for ArcGIS.
- Navigate to Content > My Content.
- On the left pane, under Folders, browse to the folder Survey-<Survey_Name> with the same name as the survey. In this example the survey name is 22555_test.
- Hover over the folder. Click Edit Folder to modify the folder name, or Delete Folder to remove the folder.
- Publish the survey from Survey123 Connect.