PROBLEM

Unable to connect to an ArcGIS Enterprise portal on devices with iOS 13 and above

Last Published: April 25, 2020

Description

Attempts to log in to an ArcGIS Enterprise portal on the Collector for ArcGIS (iOS) app and Portal for ArcGIS home page using devices with iOS version 13 and above return the following error message:

Error:   
The server you are trying to connect to (<domain_name>) is using an untrusted certificate.
Error message

Additionally, attempts to log in to an ArcGIS Enterprise portal on the Survey123 for ArcGIS app using devices with iOS version 13 and above return the following error message.

Error:   
SSL handshake failed (6)
Error 17: The root CA certificate is not trusted for this purpose
Error message

Cause

The certificates do not meet the trusted certificates requirements for iOS 13. For more information, refer to Apple Support: Requirements for trusted certificates in iOS 13 and macOS 10.15.

Solution or Workaround

To circumvent the issue, complete the steps below.

  1. Obtain trusted certificates that meet the requirements for iOS 13. Refer to the Related Information section for details.
  2. Import the certificates to Portal for ArcGIS. Refer to Portal for ArcGIS: Import a certificate into the portal for steps to do this.
Note:
Ensure all the ArcGIS Enterprise components and environments are configured with the certificates obtained in step 1.
  1. Manually install the certificates on the iOS device. Refer to the Related Information section for details.

Article ID:000022391

Software:
  • ArcGIS Collector
  • Portal for ArcGIS
  • ArcGIS Survey123 Field App iOS

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