PROBLEM

Dataset not found when publishing surveys to Portal for ArcGIS

Last Published: April 27, 2022

Description

Attempting to publish surveys from ArcGIS Survey123 Connect or ArcGIS Survey123 to Portal for ArcGIS returns the following error messages:

Error:   
Dataset not found. Status: Error. Details: code 500
Error:   
Error getting result parameter. Status: Error. Details: code 500
Error:   
Unable to create a new survey. ERROR: Dataset not found.
​​​​​The error message in ArcGIS Survey123

Cause

The given error messages indicate a broader issue. Potential causes of this error include but are not limited to:

  • Portal for ArcGIS is unable to create hosted feature layers, a core part of the publishing process.
  • The PublishingTools or the PublishingToolsEx geoprocessing services are not running or require a restart.
  • The ArcGIS Data Store license is expired.
  • ArcGIS Data Store is not validated in ArcGIS Server.
  • The user is not assigned permissions to publish hosted feature services to ArcGIS Server.
  • The Survey123 form published to Portal for ArcGIS contains only one geopoint question with the bind::esri:fieldType custom column set to null. Refer to BUG-000137465 for more information.

Solution or Workaround

  1. Review Portal for ArcGIS to ensure it is able to publish hosted feature layers. Test this by creating a layer using Portal for ArcGIS, either through a template, or by directly uploading a CSV file.
Note:
If the error is not returned for all survey forms, there may be a configuration problem or an issue with the survey XLSForm design. Republish the survey form, or refer to ArcGIS Survey123: XLSForm essentials  for XLSForm design best practices.
  1. If the error remains, check the status of the PublishingTools or the PublishingToolsEx geoprocessing services. Refer to ArcGIS Server: Start and stop services for more information.
  2. Check the ArcGIS Server Manager logs to identify the underlying cause. Refer to ArcGIS Server: Server logs for steps to access the logs.
    1. Run the describedatastore.bat utility. Refer to ArcGIS Enterprise: ArcGIS Data Store command utility reference for more information on ArcGIS Data Store command utility references.
    2. Check the Data Store mode, and Free disk space. If the Data Store mode is set to READONLY and there is available disk space, use the following command to set the relational data store to READWRITE.
changedatastoremode readonly|readwrite [--prompt <yes|no>]
Note:
The Data Store mode is automatically set to READONLY when disk-space on the machine is low, to prevent data loss.
  1. Restart the ArcGIS Data Store service in Windows.
The Command Prompt for describedatastore.bat

Article ID:000022129

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Survey123 Connect
  • ArcGIS Survey123 Website

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