PROBLEM

Unable to republish or overwrite an ArcGIS Survey123 Connect survey to ArcGIS Online or Portal for ArcGIS

Last Published: May 10, 2022

Description

When attempting to republish or overwrite an ArcGIS Survey123 Connect survey to ArcGIS Online or Portal for ArcGIS, the survey stops responding when it reaches the 'Updating survey form package' action, as shown in the image below.

Warning message

Cause

  • The survey references a different 'ownerfolder' ID leading to the survey form not found. This may occur if the ownership has changed.
  • The hosted feature layer and the form are moved from the default folder to a different folder in ArcGIS Online or Portal for ArcGIS.

Solution or Workaround

Based on the cause, the following workarounds are applicable.

  • Navigate to the new owner's C drive survey file location. For example, <C:\Users\Username\ArcGIS\My Survey Designs\<Survey_name>. Open the .itemInfo file of the survey in a text editor, and replace the ownerFolder ID with the new folder ID.
Note:
For ArcGIS Online
To determine the folder ID, right-click the name of the survey folder and select Inspect, which opens the HTML page. The folder ID is listed in the data-id attribute of the folder's <a> tag.

data-id attribute

For Portal for ArcGIS
To determine the folder ID, navigate to Portal Sharing REST > Sign in > Portals > Self > Users > User Account and go to User Content in Related Resources. Scroll to see the list of folders, and select the survey folder to view the folder ID. Refer to ArcGIS REST APIs: User Content for more information.
ownerFolder id
Note:
Alternatively, publish the survey as a new survey instead of updating the survey. This method is recommended only if there is no data collected from the old survey.

Article ID:000021874

Software:
  • ArcGIS Online
  • Portal for ArcGIS
  • ArcGIS Survey123 Connect

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic