PROBLEM

ArcGIS Enterprise and ArcGIS Online collaboration fails to sync due to a corrupt item being shared

Last Published: August 10, 2020

Description

Items shared to a group in collaboration between ArcGIS Enterprise and ArcGIS Online fail to sync. On the Collaboration page in the Portal for ArcGIS home page, the Status of Scheduled Syncs and Immediate Syncs shows Failed.

The Collaboration Sync Status in the Portal for ArcGIS REST endpoint page reports the message, "You do not have permissions to access this resource or perform this operation" for some items.

Cause

This issue occurs when the items in ArcGIS Online that must be synchronized in the collaboration are corrupted.

Solution or Workaround

To resolve the issue, follow the steps outlined to identify and delete corrupted items in ArcGIS Online.

  1. Obtain the item ID of the corrupted items.
    1. Navigate to the Portal for ArcGIS REST endpoint.
https://<Portal URL>/sharing/rest
  1. Log in with ArcGIS Enterprise (guest participant) credentials.
  2. On the User (<username>) page, click Org ID.
  3. Scroll to Portal (<Org ID>), and in the Child Resources section, click Collaborations.
  4. Click the related ID under Collaboration Id > Collaboration Workspaces. Click the related ID under Collaboration Workspace Id, and under Supported Operations, click Sync Status.
  5. Click the Status Id with failed Status. On the Collaboration Sync Status page, copy the itemId in the Status Summary as shown in the example below.
{
"taskStatusId": "e4fec91ba85548208ff4352049fce360",
"itemId": "a4049e016bc34258a9f4f5e96c76816c",
"itemTitle": "Exits",
"message": "You do not have permissions to access this resource or perform this operation."
}
  1. Delete the corrupted items.
    1. Navigate to the following URL using the item ID obtained, as shown below:
https://<organizationID>.maps.arcgis.com/home/item.html?id=<itemID>
  1. On the Item Details page, click Settings and under Delete Protection, click Delete Item > Delete.
  1. Create a new collaboration between ArcGIS Online and ArcGIS Enterprise, and sync the collaboration. Refer to Portal for ArcGIS: Set up an ArcGIS Enterprise and ArcGIS Online collaboration and Portal for ArcGIS: Configure sync settings.

Article ID:000021497

Software:
  • ArcGIS Online
  • Portal for ArcGIS

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