ERROR

Unable to create a new survey. The survey does not exist or is not accessible

Last Published: January 16, 2024

Error Message

Attempts to create a new survey in ArcGIS Survey123 using ArcGIS Enterprise credentials return the following error message:

Error:   
Unable to create a new survey. {"code":-1,"message":"","isTrusted":true}
Error message

Despite the error, an item is created but attempts to open it return the following error message:

Error:   
The survey does not exist or is not accessible.
Error message.

Further attempts to delete the item fail, and return the following error message:

Error:   
Failed to delete. undefined: Invalid account
Error message.

Cause

ArcGIS Server is configured to trust only certain domains instead of the default wildcard (*) value. The ArcGIS Survey123 domain (https://survey123.arcgis.com) is not added in the list of allowed origins.

Solution or Workaround

To resolve this issue, refer to the workflow described in ArcGIS Server: Restrict requests from Javascript applications. In the AllowedOrigins field, add https://survey123.arcgis.com.

The image below shows the ArcGIS Server Administrator Directory page after the edit is made.

An image of the ArcGIS Server Administrator Directory page.

Article ID:000021437

Software:
  • ArcGIS Server
  • ArcGIS Survey123 Website

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic