English

How To: Snap point features to a line feature

Summary

Snapping point features to a line feature is useful for accurate network analysis, and measuring the distance between two points along a line. For example, bus stops (point features) are snapped to the road (a line feature) to measure the distance between each bus stop along the road. This is done using the Snap Points And Split Lines tool. For more information, refer to ArcMap: Snapping points to lines. However, this tool is only available with a Production Mapping license.

This article describes how to snap point features to a line feature using tools with an ArcGIS Desktop Advanced license.

Point features and line feature

Procedure

  1. Use the Near tool to find the snapping locations.
    1. In ArcMap, open the Search window and search for the Near tool. Alternatively, from the ArcToolbox pane, click Analysis Tools > Proximity > Near.
    2. In the Near tool dialog box, under Input Features, select the point layer.
    3. Under Near Features, select the line layer.
    4. Check the Location (optional) check box.
    5. Click OK.
The Near tool dialog box
  1. Right-click the point layer and select Open Attribute Table. Four new fields are added to the point layer attribute table (NEAR_FID, NEAR_DIST, NEAR_X and NEAR_Y).
Four new fields are added to the point layer attribute table
  1. Export the point layer as a table.
    1. In the point layer attribute table, click Table Options > Export.
    2. In the Export Data dialog box, for Output table, click Browse.
    3. Under Save as type, select dBASE Table from the drop-down list.
    4. Click OK.
The Export Data dialog box
  1. Recreate the point layer from the table.
    1. In Table Of Contents, right-click the table and select Display XY Data.
    2. In the Display XY Data dialog box, set X Field to NEAR_X, and Y Field to NEAR_Y. Change the coordinate system if necessary.
    3. Click OK.
The Display XY Data dialog box
  1. Save the point layer permanently as a shapefile.
    1. Right-click the point layer and select Data > Export Data.
    2. In the Export Data dialog box, for Output feature class, set the shapefile name and location.
    3. Click OK.
The Export Data dialog box

The following image shows the point features are snapped to the line feature.

The point features are snapped to the line feature

Related Information