PROBLEM

Infographics does not work properly in ArcGIS Pro 2.4 if the active portal is a Geoenrichment Server instance without a dataset corresponding to the identified Windows Locale country

Last Published: April 25, 2020

Description

Infographics does not work properly in ArcGIS Pro 2.4 if the active portal is a Geoenrichment Server instance without a dataset corresponding to the identified Windows Locale country.

Cause

This issue encountered when the Geoenrichment Service GlobalIntersect request is unable to identify the country selected with the Infographics cursor. This results in failure to populate ‘Configure Infographics’ with the selected country dataset and the following message is returned:

"Data is not available for country <Windows Locale Country>."

Solution or Workaround

If encountered, this issue can be bypassed by the following steps to select the country to run Infographics within from the Configure Infographics window.

  1. Click the Infographics drop-down and select Configure Infographics.
  1. In the Show available data for drop-down, select the country to click within to return data, using the Infographics cursor.
  1. Click OK to close the Configure Infographics window.

    Upon completion of these steps, Infographics templates are returned populated with data for the feature clicked within the country assigned in Configure Infographics.

Article ID:000021351

Software:
  • ArcGIS Business Analyst Pro
  • ArcGIS Pro 2 x

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