English

Problem: Exporting the query result to a CSV file from the attribute table using the Query widget fails in Web AppBuilder for ArcGIS

Description

In Web AppBuilder for ArcGIS, attempts to export the query result from an attribute table using the Query widget (by clicking View in Attribute Table > Options > Export to all CSV) fail to download the CSV file without any warning or error message.

Cause

This is a known limitation in Web AppBuilder for ArcGIS. Refer to BUG-000123249, BUG-000118708, and BUG-000113626 for more information and the current status of the bugs.

Solution or Workaround

As a workaround, export the query result directly, without viewing the result in the attribute table.

  1. In Web AppBuilder for ArcGIS, add and configure the Query widget This is the Query widget..
  2. In the Configure Query window, click New query.
  3. Select a layer and click OK.
  4. Specify the query and settings in the Info, Filters, and Results tabs.
  5. In the Options tab, check the Allow to export results check box. Click OK.
This is the Configure Query window
  1. In the map view, click the Query widget. The Query window opens.
  2. In the Tasks tab, select the layer to export.
  3. In the Results tab, click the Feature actions icon The Feature actions icon.. Select the desired option to export the query result.
Multiple export options
Once the desired export option is selected, the CSV file automatically downloads.
This is the CSV download

The following alternatives are also available using the Attribute Table widget, Select widget, or Analysis widget to export or extract a subset or the entire data from Web AppBuilder for ArcGIS:

Use the Attribute Table widget

This option is to export the entire or partial data from the attribute table.

  1. In Web AppBuilder for ArcGIS, add and configure the Attribute Table widget This is the Attribute Table widget.
  2. In the Configure Attribute Table window, check the Allow exporting to CSV check box.
  3. Click OK.
This is the Configure Attribute Table window.
  1. Expand the attribute table. Click Options > Export all to CSV to export the entire data. To export a subset of data, configure the Filter function before exporting.
This is the 'Export all to CSV' option

Use the Select widget

This option is to export the selected features.

  1. In Web AppBuilder for ArcGIS, add and configure the Select widget This is the Select widget.
  2. In the Configure Select window, check the Allow exporting selected features check box.
  3. Click OK.
This is the Configure Select window
  1. In the map view, click the Select widget. The Select window opens.
  2. Click the desired layer and manually draw on the map to select the desired data.
  3. Click the Show actions on selected feature(s) icon More actions icon. Choose the desired export option.
These are the export options

Use the Analysis widget

This option is to export analysis results.

  1. In Web AppBuilder for ArcGIS, add and configure the Analysis widget This is the Analysis widget.
  2. In the Configure Analysis window, select Extract Data.
  3. Click the Set tool details icon The Set tool details icon. of the selected analysis and check the Allow to export results check box.
  4. Click OK.
This is the Configure Analysis window
  1. In the map view, click the Analysis widget. The Analysis window opens.
  2. Select the layer(s) to extract, and specify the export option. Click Run Analysis.
This is the Analysis widget

Related Information