PROBLEM

Hosted feature layers fail to publish to a portal with Error 001362 and Error 001360

Last Published: April 25, 2020

Description

When publishing hosted feature layers to a portal, the following errors are returned:

Error:   
Error 001362: Failed to extract manifest from uploaded service definition
Error:   
Error 001360: Failed to get basic item metadata for service definition upload

Cause

Some known causes for these errors are, but are not limited to, the following:

ArcGIS Data Store is unable to communicate with ArcGIS Server or Portal for ArcGIS through the established SSL protocols
The SSL protocols configured or enabled for the machines with ArcGIS Data Store, Portal for ArcGIS and ArcGIS GIS server are not the same. All machines are required to have the same SSL protocols in order to successfully publish the hosted feature layers.

Publishing tools are unable to download the service definition file from the portal to the Temp folder of the ArcGIS Server account
When a hosted feature layer is published, the publishing tool of the hosting server downloads the service definition file from the portal to the Temp folder of the account running the ArcGIS Server service on the machine.

This download fails if:

  • The ArcGIS Server service account does not have the appropriate permissions to the folder.
  • The disk drive where the Temp folder is stored is full.
  • The Temp folder contains over 65,000 files (this limit varies based on the operating system).

Solution or Workaround

Use one of the following solutions depending on the cause:

ArcGIS Data Store is unable to communicate with ArcGIS Server or Portal for ArcGIS through the established SSL protocols
  1. Determine the SSL protocols used by ArcGIS Server and Portal for ArcGIS.
    1. To check the current SSL protocol used by ArcGIS Server, log in to the ArcGIS Server Administrator Directory (https://<machine>.<domain>.com/<serverwebadaptor>/admin) as an administrator. 
    2. Click security > config. Take note of the TLS versions enabled next to SSL Protocols.
Note:
TLS v1.2 and TLS v1.1 are the default SSL protocols for base deployment of ArcGIS Enterprise starting at version 10.6.1.
  1. To check the current SSL protocol used by Portal for ArcGIS, log in to the Portal Administrator Directory (https://<machine>.<domain>.com/<portalwebadaptor>/portaladmin) as an administrator. 
  2. Click Security > SSLCertificates.  Take note of the TLS versions enabled, which are listed in the Web Server SSL Protocols field.
Note:
Ensure the ArcGIS Server and Portal for ArcGIS protocols match. For more information on setting protocols in ArcGIS Server and Portal for ArcGIS, refer to ArcGIS Server: Secure ArcGIS Server communication (for ArcGIS Server) and Portal for ArcGIS: Restrict TLS protocols and cipher suites (for Portal for ArcGIS).
  1. Enable the protocols for each machine.
    1. On the ArcGIS Server machine, open the Services application from the Windows Start Menu.
Note:
The Services application can be found by searching from the Windows Start Menu, or by typing services.msc in the Start > Run dialog, and pressing Enter.
  1. Take note of the owner of the ArcGIS Server service under the Log On As column.
  1. Log in to the ArcGIS Server machine as the account running the ArcGIS Server service.  
  2. From the Windows Start Menu, search for and click Internet Options.
  3. In the Advanced tab, browse the Settings section and check the protocols that match with Step 1.
Note:
It may be may required to check with the IT department to change these protocols.
  1. Repeat Steps a through e for the machines installed with Portal for ArcGIS and ArcGIS Data Store.
Publishing tools are unable to download the service definition file from the portal to the Temp folder of the ArcGIS Server account
  1. Give the ArcGIS Server account full control to its Temp folder.
    1. On the ArcGIS Server machine, open the Services application from the Windows Start Menu.
    2. Take note of the owner of the ArcGIS Server service under the Log On As column.
    3. Log in to the ArcGIS Server machine as the account running the ArcGIS Server service.
    4. In Windows File Explorer, navigate to the Temp folder.
Note:
The default location for the temporary folder can be found at C:\Users\Default\AppData\Local.
  1. Right-click the folder and click Properties > Security.
  2. Highlight the ArcGIS Server service account and check the box next to Full control under Permissions for. Click Apply.
  1. Check the available disk space on the disk drive where the Temp folder of the ArcGIS Server service account is located.
    1. In Windows File Explorer, right-click the drive where the Temp folder is located (this is often the C drive). Click Properties
    2. Check the amount of free space here. If there is little or no free space, click the Disk Cleanup button to clear unnecessary files.
  1. Clear files stored in the Temp folder.
    1. Navigate to the Temp folder. Right-click the Temp folder and click Properties.
    2. In the General tab, check the number of files found. If this number is beyond the limits of the operating system, remove files that are no longer needed.

Article ID:000019726

Software:
  • ArcGIS Server
  • ArcGIS Data Store
  • Portal for ArcGIS

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