ERROR

The userId [userID] does not match a named user in your organization and is active in your project. See more info on how to remove the user from this project

Last Published: September 30, 2022

Error Message

When an administrator attempts to remove a user with the Mobile Worker role from a ArcGIS Workforce project, the following error message is returned:

Error:   
The userId [userID] does not match a named user in your organization and is active in your project. See more info on how to remove the user from this project.

In the USERS tab, the user ID of the mobile worker shows invalid but the role is displayed as 'Active' in the ArcGIS Workforce application. In some instances, when the USERS tab is clicked, the content is blank. The images below show the error message with the invalid userID and the blank content.

The error message
The blank content

Cause

This issue occurs if the user with the Mobile Worker role has started or completed work assignments assigned to them in a project, or the work assignment is in progress.

Solution or Workaround

To delete users with the Mobile Worker role from the ArcGIS Workforce application, use one of the following workarounds:

For assignments not started or completed

Re-assign the assignment to another user with the Mobile Worker role and delete the previous user in the ArcGIS Workforce application. Refer to ArcGIS Workforce: Manage work for instructions.

For assignments in progress or completed

Re-assign the assignment at the feature service level in ArcGIS Online. Follow the instructions described below:

  1. In ArcGIS Online, click Content > My Content and navigate to Folders.
Content and My Content pane
  1. Click the folder containing the desired ArcGIS Workforce assignment and click the worker feature layer.
Folder and worker feature layer pane
  1. Click Data > Table and click the Options button. Select Show/Hide Columns.
Data and table pane with the option button
  1. Check the ObjectID or GlobalID check box. Identify the ObjectID or GlobalID of the previous user to be deleted and the new user to be re-assigned the assignment.
ObjectID check box
ObjectID of users
Note:
Workers are identified by ObjectID or GlobalID. The ObjectID or GlobalID is used to change the WorkerID of the assignment.
  1. Open the assignment layer in Map Viewer and change the WorkerID of the assignment to the new user's ID:
    1. Open the assignment in Map Viewer and in the Contents pane, click Show Table.
Contents pane
  1. In the table, double-click the assignment WorkerID to change the ObjectID or GlobalID to the new mobile worker's ID, and click Save.
Table with WorkerID
  1. Open ArcGIS Workforce and delete the previous user.

Article ID:000019491

Software:
  • ArcGIS Online
  • ArcGIS Workforce

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic