ERROR

Unable to auto-detect delimiting character; defaulted to ','

Last Published: April 25, 2020

Error Message

A survey using the pulldata() function to obtain the information saved in a CSV file loads successfully in the Survey 123 for ArcGIS Connect but returns the following error in the Survey 123 for ArcGIS Web form:

Error:   
Error: Initialing Form...
Unable to auto-detect delimiting character; defaulted to ','
Error message

Cause

The error is caused by a null line in the CSV file. When the CSV file is opened in a text editor such as Notepad ++, an extra null line can be seen without any information or data available, as displayed in the image below. The Survey 123 for ArcGIS Field app ignores the null line. However, the Survey 123 for ArcGIS Web form is sensitive to the null line.

Null line

Solution or Workaround

To resolve this issue, open the CSV file in a text editor such as Notepad ++ and delete the null line. Save the contents. Publish the survey again using the Survey 123 for ArcGIS Web form. For more detailed steps, refer to Publish your survey.

Article ID:000019311

Software:
  • ArcGIS Survey123 Field App iOS

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