ERROR

001812: Unable to connect to the database used for scene caches

Last Published: May 14, 2021

Error Message

Attempts to publish a web scene using ArcGIS Pro fail and the following error message is returned:

Error:
Error 001812: Unable to connect to the database used for scene caches (The publishing tool could not connect to the tile chache data store. This may be due to security settings that affect how the hosting server communicates with the tile cache data store. To resolve this, contact the ArcGIS Data Store administrator and ask the administrator to review changedbproperties utility information in the ArcGIS Enterprise help.).
The image of the Error 001812 message

Cause

ArcGIS Pro is installed on a machine with Windows Internet Options settings that distrust the ArcGIS Data Store hosting server. This stops ArcGIS Pro from connecting to the data store because the cache is not generated.

Solution or Workaround

To establish trust between the ArcGIS Pro machine and the ArcGIS Data Store hosting server, allow list the server URL. The following are steps to do so:

  1. Log in as the ArcGIS Server account.
  2. Click the Windows button, search Internet Options, and open the Internet Options window.
  3. Click the Security tab.
The image of the Security tab on the Internet Options window
  1. Select Trusted Sites and click Sites > OK.
The image of the Trusted Sites tab.
  1. Uncheck the Require server verification (https:) for all sites in this zone checkbox.
  2. In the Trusted sites window, add the following URLs:
The image of the Trusted sites window.
  • http://<domain name of ArcGIS Data Store>
  • https://<domain name of ArcGIS Data Store>
  • http://127.0.0.1

Article ID:000018751

Software:
  • ArcGIS Data Store
  • ArcGIS Pro 2 8 x
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

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